S3 storage 404 GET error

Hello,

I have been trying to setup S3 storage with my Seafile setup (done in docker/portainer, using nginx proxy manager for HTTPS), creating 3 buckets using various services (I’ve tried Wasabi and Linode), one for each commit, fs and block backends, and configuring Seafile.conf to look like the following:

[commit_object_backend]
name = s3
bucket = something-commit
key_id = your-key-id (replaced with my actual key id)
key = your-secret-key (replaced with my secret key)
host = ap-south-1.linodeobjects dot com (dot was replaced with . and no spaces)
path_style_request = false
memcached_options = --SERVER=localhost --POOL-MIN=10 --POOL-MAX=100

[fs_object_backend]
name = s3
bucket = something-fs
key_id = your-key-id (replaced with my actual key id)
key = your-secret-key (replaced with my secret key)
host = ap-south-1.linodeobjects dot com (dot was replaced with . and no spaces)
path_style_request = false
memcached_options = --SERVER=localhost --POOL-MIN=10 --POOL-MAX=100

[block_backend]
name = s3
bucket = something-block
key_id = your-key-id (replaced with my actual key id)
key = your-secret-key (replaced with my secret key)
host = ap-south-1.linodeobjects dot com (dot was replaced with . and no spaces)
path_style_request = false
memcached_options = --SERVER=localhost --POOL-MIN=10 --POOL-MAX=100`

To my dismay, after configuring the .conf as such, when I click on my library in Seafile I’m greeted by a blank screen where nothing loads, with the console showing a 404 GET error (see the red error below). However, I see folders created in my buckets so Seafile is certainly not having issues uploading to it.

This is what is shown in seahub.log:
2020-12-31 06:33:44,548 [WARNING] django.request:152 get_response Not Found: /api/v2.1/repos/d2e0e1c5-71b1-470a-86c0-76a1a84a272c/

And seafile.log:
[12/31/2020 06:35:06 AM] repo-mgr.c(1116): Commit d2e0e1c5-71b1-470a-86c0-76a1a84a272c:8a92fca0659f739c82e44e4624879308ec6feab3 is missing

In addition, everything works fine without the S3 configuration, meaning it should not have anything to do with my base Seafile config as I am able to upload, view etc. files in my library when S3 storage is not configured.

I have tried messing with numerous things, including turning path_style_request to true/false, trying different bucket providers (Wasabi and Linode), setting memcached_options = --SERVER=memcached instead of localhost, setting use_https = true but nothing has worked so far. It might be worth mentioning in regards to setting https = true but I did not follow these steps in the manual as I was unable to find the system CA bundle in the given directory:

Because the server package is built on CentOS 6, if you're
using Debian/Ubuntu, you have to copy the system CA bundle to CentOS's CA bundle path. Otherwise Seafile can't find the CA bundle so that the SSL connection will fail.

sudo mkdir -p /etc/pki/tls/certs
sudo cp /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt
sudo ln -s /etc/pki/tls/certs/ca-bundle.crt /etc/pki/tls/cert.pem

However, I presume that it is not the cause of the issue I’m encountering as it still happens when https is false/unspecified.

For the record I am running on the pro version. Does anyone know what’s going on? I’ve been racking my head for hours and can’t find many resources even regarding setting up S3 with Seafile outside of the official manual.