Save to Seafile in IOS client - where do pictures/files go?


#1

Hi all - hopefully a simple question. I’m using Seafile 2.6.8 on IOS 11.0.3 (iPhone 5S if it matters). While trying to save some pictures from an iMessage thread, I found a new-to-me feature in the share menu - Save to Seafile. I’ve tried it a couple of times, selecting my server and authenticating when prompted. It returns me back to the iMessages screen when done authenticating, but doesn’t provide me a prompt for which folder in My Library to save the image to. I’ve resync’d and checked through various folders in My Library trying to find where/if it’s saving images to, but can’t seem to locate them. Can someone confirm if this feature is active/enabled, and if so, where the default location is that files are saved to?

Thanks in advance,

Jason


#2

New update - I went to save a voicemail from my phone to the Seafile server, so I clicked the Share button, selected Save to Seafile, and authenticated to the server. Unlike when I tried to save a picture previously, it pulled up My Library on Seafile. I tried to put it into a specific subfolder, but got an error message saying “Failed to load content of the directory”. I backed out into the main folder, then hit the Save button in the upper right. I get a pop-up that says “Uploading voicemail-526.m4a” (presumably to the main folder), but it never seems to complete. I’ve canceled and tried to redo it a few times with no success, and I don’t see the file in my Seafile library.

Is this a bug/feature that’s not enabled yet, or is there some kind of permissions error I’m having between the IOS client and my Seafile server? Although I have v2.6.8 of the IOS client, I’m running an older v5.1.3 server on Windows 10 Pro as I haven’t gotten comfortable yet with how to migrate to the Docker versions. There is no HTTPS currently on this server.

Any thoughts/help would be appreciated. This is a great feature I’d love to take advantage of! :slight_smile:

Thanks…

Jason


#3

Bumping this back to the top… :slight_smile:

I did some additional testing using my wife’s iPhone 6S (IOS 11.0.3 with Seafile client v2.6.8). I went into Photos, clicked the share button, clicked “More” and enabled “Save to Seafile”, and hit the Done button. I then went back to the menu and hit “Save to Seafile”. The first time I tried it, it had me authenticate, select where to save, at which point there was a pop-up that said “Uploading (null)”. It never completed or went away, so I canceled and tried again. The second time it said “Uploading…” with the filename of the picture after it, but again, never completed after about 20 minutes of waiting.

Is anyone else using this feature and experiencing these issues? I’m trying to determine if it is a configuration problem with my Seafile server (and/or network), a limitation of my Seafile v5.1.3 server that requires an upgrade to work, or if the feature simply isn’t operational yet. If there are logs or other info I can provide, I’m happy to do so.

Thanks!

Jason


#4

And again to the top. In case it’s a case of TL;DR, to summarize,

  • Does the “Save to Seafile” option in the IOS client work?
  • If so, is it dependent on a certain server version?
  • If it does work and it’s not dependent on a server version, where does it/should it save the files?

This would be a great help to be able to offload some files from my phone directly to Seafile, but it just won’t work for me. If it’s a feature that’s not enabled or not compatible with my v5.1.3 server, I’d just like to know so I can stop futilely trying it. :slight_smile: If it should work, I’d love to do some troubleshooting to see if it can be made to do what it says.

Thanks!

Jason


#5

I’m +1’ing on @rotaryracer’s questions and, in the meanwhile, I’d like to share a workaround which allowed me to successfully upload a file to specific folder (sic!) at my Seafile.

  1. Open “Files” iOS stock app, see if you see Seafile in the list of locations. If it’s not there, tap “Edit” at top-right and you should be able to enable it.
  2. Try to share some file (in my example it was a PDF from Acrobat app) and use “Save in Files” (in 2nd row, under usual “Copy to-s”)
  3. Magically be able choose Seafile and any folder in any library :slight_smile:

This worked on iOS 11.4.1, Seafile Pro app v2.7.8.