Seadrive and Archlinux

Has anyone successfully managed to get the Seadrive Client running under Arch Linux? I know that Arch isn’t officially supported, but as Seadrive is now Open Source, I was hoping that someone might have had more success than I did.

Yes I was able to get both the client and drive packages installed and working. I used the AUR packages

Search the AUR repo for both seafile-client and seadrive-gui

Thanks for that. I had conflicting dependency issues (ie: I could install Seafile or Seadrive, but not both). Perhaps I should give Arch another try!

I’ve just done a fresh install of Arch. When I do:

yay seadrive-gui

I gen an error saying that one or more PGP sugnatures could not be verified. And it fails…

==> Validating source files with sha256sums...
libevent-2.0.22-stable.tar.gz ... Passed
libevent-2.0.22-stable.tar.gz.asc ... Skipped
openssl_1.1.patch ... Passed
0001-evdns-fix-searching-empty-hostnames.patch ... Passed
0002-test-dns-regression-for-empty-hostname.patch ... Passed
0003-evdns-name_parse-fix-remote-stack-overread.patch ... Passed
0004-evutil_parse_sockaddr_port-fix-buffer-overflow.patch ... Passed

==> Verifying source file signatures with gpg…
libevent-2.0.22-stable.tar.gz … FAILED (unknown public key 910397D88D29319A)
==> ERROR: One or more PGP signatures could not be verified!
error downloading sources: libevent-compat

OK: I had to do this:

    gpg --recv-keys 910397D88D29319A
Then yay seadrive-gui worked!

Just an NB:

Although the solution I posted (above: 01/02/21) worked on Arch Linux, it didn’t work on Endeavour OS. So it might not work on other Arch-based distros (Manjaro, etc).

But this did work:

gpg --keyserver --recv 910397D88D29319A

A further NB, this for Manjaro:

Install yay from Github, not via pacman.
run sudo pacman -S --needed base-devel
then yay seadrive-gui will work.