Seadrive broken after Windows 11 23H2 update

Might be coincidence but just done a test upgrade of my Lenovo AMD laptop to Windows 11 23H2. After which Seadrive won’t load with multiple errors:




I’m also unable to uninstall:


Fortunately, I took an image before upgrading… been burnt before! I do notice that I was running an old version of Seadrive on my laptop.

Hmm, this might be unrelated. Occurs on the restored image. Going back further in time.

I rolled laptop back, upgraded Seadrive to 3.0.6 and then installed 23H2. That appears to have worked fine. Might have messed something up before but maybe make sure Seadrive is up to date before upgrading.

Oh god, wouldn’t be just easier to purge that old crapped version and install a new one without the whole system roll back? Also some runtime libraries (VS Runtime 2019 or something) could fix that - you should search that on net about those missing dll files - you would get an answer.

Possibly yes after it occurred again but I regularly image my computers - as an IT bod/developer, it’s not unusual for me to tank my computer :wink:

However, it happened again so this time I tried to uninstall Seadrive - got this error:

So I tried re-installing from the MSI and was offered “Repair”. That seems to have worked.

I think 23H2 is a red herring as after restoring, I didn’t install 23H2 (so the 2nd error was 22H2). However, I did upgrade VMware Workstation and this upgrades Microsoft VC Resistributable:

The errors I posted first are DLLs in that package aren’t they?