SeaDrive Client 2.0.16 on Seafile Pro Server

Hello! I use the Seadrive Client on different macOS devices. Unfortunately, I recently got the message that a certain library was too big and therefore could not be synced. It is 1.1 TB in size and was previously displayed on without any problems. Does the storage space on the client have to be exactly as large as the library on the server? The console shows the following errors:

[08/29/21 12:37:42] http-tx-mgr.c(1302): Transfer repo ‘e75d0ea6’: (‘normal’, ‘commit’) → (‘normal’, ‘fs’)
[08/29/21 12:37:42] http-tx-mgr.c(4564): Bad response code for GET https://seafile./seafhttp/repo/e75d0ea6-297a-4ca0-b99b-feb841809d77/fs-id-list/?server-head=037ae02a25a3b25234ff3df3fa67737c6180991b&dir-only=1: 447.
[08/29/21 12:37:42] http-tx-mgr.c(5250): Failed to get fs id list for repo e75d0ea6 on server https://seafile.
.
[08/29/21 12:37:42] http-tx-mgr.c(1302): Transfer repo ‘e75d0ea6’: (‘normal’, ‘fs’) → (‘error’, ‘finished’)
[08/29/21 12:37:42] sync-mgr.c(778): Repo ‘*’ sync state transition from downloading to ‘error’: ‘Error occured in download.’.

Sensitive info was replaced by *

Thanks for any hint!

Let me guess, you updated the Seafile Server recently?!

Hm, nope, no serverupdate between functional and nonfunctional library sync, it happens one day to another.

I deleted .seadrive under /user (macos 11.5.2) to force a complete new installation of seadrive (new filelist and so on), but this did not help. The problem is on different machnes the same, so no local problem, i guess.

What can i do on serverside, to solve the problem? I restartet the server.

Hello,seadrive can’t sync a repo with a large number of files.If you wan’t to sync such repo,you’d better to split to multiple repos.The option ‘max_sync_file_count’ in seafile is 100000 by default.You can also modify this option.

Is this new to seadrive, new fuse version, maybe?

We´ve set max_sync_files to 99999999. But no way, no sync possible. Is there a hardcap, that need to be communicated for seadrive, such as maxium files per repo XXXXXX?

That would be good to know, in general.

go to the conf folder on your seafile server, in the seafile.conf file enter these 2 lines

max_sync_file_count = 1000000000
fs_id_list_request_timeout = -1

We did it, but only the error message of seadrive changes (447 to 408):

Bad response code for GET https://seafile.DOMAIN/seafhttp/repo/e75d0ea6-297a-4ca0-b99b-feb841809d77/fs-id-list/?server-head=6bd3b03ff8e4fd24997ddee4c0fa200c0898f403&dir-only=1: 408.
[08/31/21 18:06:13] http-tx-mgr.c(5250): Failed to get fs id list for repo e75d0ea6 on server https://DOMAIN
[08/31/21 18:06:13] http-tx-mgr.c(1302): Transfer repo ‘e75d0ea6’: (‘normal’, ‘fs’) → (‘error’, ‘finished’)
[08/31/21 18:06:13] sync-mgr.c(778): Repo ‘.’ sync state transition from downloading to ‘error’: ‘Error occured in download.’.

Have you configured the proxy? If you do, you also need to modify the proxy timeout.

Our shortest timeout is 1200s - should actually work, right?

I have to add that the database has been checked for consistency (FSCK). Does anyone have such a large database and it works with Seadrive? (about 220k files)

And i should say: The SeaFile Client is working fine, no errors there - only SeaDrive wont sync.

Is your config like this?

Hello!

Yes, but max sync files count significant higher, on a test basis ;)! Some repos wont sync, so far we have no solution.

Which version of Seafile server do you run? Can you post your seafile.conf on the server?

Hello jonathan,

we use Seafile 8.0.4. Pro. Here is the seafile.conf:

[fileserver]
port = 8082
max_upload_size = 99999999
max_sync_file_count = 99999999
fs_id_list_request_timeout = 300
max_download_dir_size = 65536

[database]
type = mysql
host = mysql
port = 3306
user = seafile
password = db-passwd
db_name = seafile-db
connection_charset = utf8