Seadrive Failed to stat block

Windows server 6.0.7. All clients use seadrive 5.2. Today, one client’s files were not showing up on other’s S: drives.
I’ve checked their AV (mse) on their comp. Nothing in the log files.
Their log file says:

[03/12/17 03:05:08] sync-mgr.c(376): Repo ‘My Library’ sync state transition from ‘synchronized’ to ‘uploading’.
[03/12/17 03:05:08] http-tx-mgr.c(3761): Upload with HTTP sync protocol version 1.
[03/12/17 03:05:08] http-tx-mgr.c(1052): Transfer repo ‘64f14355’: (‘normal’, ‘init’) --> (‘normal’, ‘check’)
[03/12/17 03:05:08] http-tx-mgr.c(1052): Transfer repo ‘64f14355’: (‘normal’, ‘check’) --> (‘normal’, ‘commit’)
[03/12/17 03:05:08] http-tx-mgr.c(1052): Transfer repo ‘64f14355’: (‘normal’, ‘commit’) --> (‘normal’, ‘fs’)
[03/12/17 03:05:08] http-tx-mgr.c(1052): Transfer repo ‘64f14355’: (‘normal’, ‘fs’) --> (‘normal’, ‘data’)
[03/12/17 03:05:08] block-backend-fs.c(224): [block bend] Failed to stat block 64f14355-a91f-41ad-aed1-ba2b0583aeb8:cf38a6d486d2592d645624e1b425e6775d8071e4 at C:/Users/Bob Jones/seadrive/data\storage\blocks/64f14355-a91f-41ad-aed1-ba2b0583aeb8/cf/38a6d486d2592d645624e1b425e6775d8071e4: No such file or directory.
[03/12/17 03:05:08] http-tx-mgr.c(3417): Failed to stat block cf38a6d486d2592d645624e1b425e6775d8071e4 in repo 64f14355-a91f-41ad-aed1-ba2b0583aeb8.
[03/12/17 03:05:08] http-tx-mgr.c(1052): Transfer repo ‘64f14355’: (‘normal’, ‘data’) --> (‘error’, ‘finished’)
[03/12/17 03:05:08] sync-mgr.c(406): Repo ‘My Library’ sync state transition from uploading to ‘error’: ‘Error occured in upload.’.

No errors on any other client. Ran a fsck on the server just in case. Seems ok. How do I fix this?


Can you send the full seadrive.log for analysis? I think there should be some bugs causing this problem. Some other users also reported this. Also can you ask what operation the user did to that file?

To fix the problem at the moment, just logout and login the account again.

here. logging out and in fixed it. Two questions, is there any automated way to deal with the conflict files generated? or is the best way just to check out the two copies and delete the unneeded one?
Also, Is there any option to show a ‘hey, I can not upload!’ error to user so we can catch it quickly? (instead of just noticing files not being there)
I tried to attach the file but txt isn’t authorized so here it is:

Thanks for the log. But it doesn’t seem to be the complete log. Could you add the pieces of log messages before this error first occurred in the log? That should be more helpful to pinpoint the problem.

In 0.6 version we’ll add error notification when upload fails.

For conflict files, just keep the correct version and delete the unneeded one.

Whoops sorry about that. I hacked up that log.
So it started again, I notice that once it starts asking ‘copy this file without properties?’ that means the error is happening.
here is a link to log again. I didn’t mess with it at all.
All i was doing was copying files.

Thanks for the information. We’ve reproduced the bug by copying files from Dropbox folder into SeaDrive. This bug will be fixed in the next version.


I’ve got exactly same errors (as first post) but with “classic” desktop clients… (not SeaDrive)
Happen on different desktop client OS (Linux, Mac OS, Windows) and different version (5.11, 6.0.4, 6.0.1…)

According to you is the same problem ?

Thank you

@Romain This problem recently happened to some users too. Does this problem still happening to your users? Can you tell what operations would cause it?

@Jonathan It seems that it doesn’t happen often anymore… the last one happened 17 days ago.
I check it in admin panel for two people on the same library, and for another user on another library, it seems to happen on “download-sync” operation.
It can happen when there’s a file update or not (according to log in admin panel : on case I check, it happens for one but not for the other…)

Thank you

If it happens in download, it shouldn’t be the same issue. The issue here only happens in upload.