SeaDrive fails to upload + possible cause

I’ve recently set up Seafile community edition (6.0.8) on my server and installed SeaDrive (0.5.1) on my Windows machine. I’ve been trying to upload some files via SeaDrive, they were going fine for a while then it stopped. I checked the log and see the following over and over, and I cannot get it to upload any new files, even if I delete that folder and try a different one:

[03/07/17 20:32:57] sync-mgr.c(376): Repo 'My Library' sync state transition from 'synchronized' to 'uploading'.
[03/07/17 20:32:57] http-tx-mgr.c(3736): Upload with HTTP sync protocol version 1.
[03/07/17 20:32:57] http-tx-mgr.c(1052): Transfer repo 'da080b33': ('normal', 'init') --> ('normal', 'check')
[03/07/17 20:32:58] http-tx-mgr.c(1052): Transfer repo 'da080b33': ('normal', 'check') --> ('normal', 'commit')
[03/07/17 20:32:58] http-tx-mgr.c(1052): Transfer repo 'da080b33': ('normal', 'commit') --> ('normal', 'fs')
[03/07/17 20:32:58] http-tx-mgr.c(1052): Transfer repo 'da080b33': ('normal', 'fs') --> ('normal', 'data')
[03/07/17 20:32:58] block-backend-fs.c(224): [block bend] Failed to stat block da080b33-24e9-4bb4-a9b2-0393d6957129:dae37f3ceb50ada7be0154ef4b8668c52b810308 at C:/Users/Rob/seadrive/data\storage\blocks/da080b33-24e9-4bb4-a9b2-0393d6957129/da/e37f3ceb50ada7be0154ef4b8668c52b810308: No such file or directory.
[03/07/17 20:32:58] http-tx-mgr.c(3392): Failed to stat block dae37f3ceb50ada7be0154ef4b8668c52b810308 in repo da080b33-24e9-4bb4-a9b2-0393d6957129.
[03/07/17 20:32:58] http-tx-mgr.c(833): libcurl failed to PUT Operation was aborted by an application callback.
[03/07/17 20:32:58] http-tx-mgr.c(1052): Transfer repo 'da080b33': ('normal', 'data') --> ('error', 'finished')
[03/07/17 20:32:58] sync-mgr.c(406): Repo 'My Library' sync state transition from uploading to 'error': 'Error occured in upload.'.

I’ve tried uninstalling SeaDrive, deleting the “seadrive” local folder, installing SeaDrive again and copying the files back in, but I get the same set of errors.

I notice that with “C:/Users/Rob/seadrive/data\storage\blocks/da080b33-24e9-4bb4-a9b2-0393d6957129/f3/” the “f3” directory does not exist and “C:/Users/Rob/seadrive/data\storage\blocks/da080b33-24e9-4bb4-a9b2-0393d6957129/da/e37f3ceb50ada7be0154ef4b8668c52b810308” the “e37f3ceb50ada7be0154ef4b8668c52b810308” file does not exist.

(I notice too that it is using a mix of forward and back slash, though I doubt this is the cause of the issue it just something spotted)

When adding files I am copying them from my current Dropbox folder. I’m wondering if if has something to do with how they get copied in, when copying Windows says that the files cannot be copied with all of their properties, do you want to continue. When this happens, the above errors seem to occur.

edit edit
I’ve tried a couple of times now and its looking more like this occurs when you try to copy multiple files and Windows asks what to do when it cant copy all file properties. Maybe it partially copies a file, then wait for user input and that causes issues?

Hope someone is able to help.

Do you have anti virus software installed on your computer? Perhaps the block file was deleted by anti-virus software. Since a block is a chunk from a file, it can sometimes be detected as virus.

Can you upload the complete log file to somewhere for my analysis? I have to see what error happened when the files are copied in.

Thanks for your replies. It doesn’t appear to be an issue with Anti virus as that hasn’t removed any files from there (I check logs). I tried today and haven’t been able to replicate the issue again (though I have now copied everything in). But I will try and and keep an eye out and update if it happens.

We’ve reproduced the bug when will fix it in upcoming 0.6 version.