Seadrive install fails, claiming an older version was present

Seadrive install fails, claiming an older version was present.
Previous uninstall of the older version had problems, but the Seadrive icon is gone in the Windows Apps List.
I described the error messages earlier in begin of january, but didn’t get any answer.

Is Dokany still installed? Please uninstall it and try again.

That was one of the first steps, which I tried. I’ve reinstalled Dokany in the version

Not sure I understand.
Did that reinstallation of Dokany have any effect?
If Dokany is installed, then please uninstall it and try installing SeaDrive using the SeaDrive installer.

No the reinstallation of Dokany had no effect.

List the whole story:
In the time I used SeaDrive v0.97 successfully, another version of Dokany was already installed. I tried to update SeaDrive to the newest version, as I was suggested by SeaDrive.
That trial was not successful and terminated with an error message.
So I tried to uninstall the old version of SeaDrive to make a fresh install. But also the uninstall of the old SeaDrive terminated with an error message, while the listing of SeaDrive in the Windows Apps list was deleted now.
Now, trying to install the New SeaDrive for new, the install process was aborted with another error message, complaining another version of SeaDrive was already installed.
Checking the details I found that an outdated Dokany version might be the cause.
So I uninstalled the old Dokany and installed Dokany version which, as I read was the suitable Dokany for the recent SeaDrive. Again I tried to install SeaDrive, but it is still aborted with error.

Hi Hans11,

I have no silver bullet for you. Sorry.

I would try to do this:
Check your the registry for orphaned entries related to Seafile/SeaDrive. I am not at all a fan of registry cleaners (i.e. Ccleaner), but this is may be one of the cases, where they may come in handy. Please back up your registry before using it!
Make sure to delete these two folders:

  • C:\Program Files (x86)\SeaDrive
  • C:\Users\USERNAME\seadrive

If this does not help, please disable your AV programm and try again.

Thank You for thinking about thisl

  • The files and folders are deleted.
  • I have already checked the registry for all entries containing SeaDrive and removed them. There is no entry containing “SeaDrive” found with the Search function in the Registry Editor. Nevertheless during the install procedure SeaDrive claims there was an older version installed.
  • I have no idea, which check the programmers have programmed into their install procedure.
    Obviously the programmers do not look into their own Forum, as they do not comment on this. It’s a pity.
  • But the SeaFile program works at the end.

Hi Hans11,
you expect the developers of a software, that you probably use free of charge, to fix a problem specific to your computer? Well …
Anyway, I am glad it works now. What did you do?

No, sorry, You misunderstood me:

  • SeaFILE is, what’s working perfectly
  • SeaDRIVE still fails to install

Regarding the “complaint” of presumed non-paying users: I guess, our company does pay for the license, we use.
But nevertheless, I would expect, that developers have an own interest in tracking problems in their software. And looking into the small number of posts regarding SeaDrive, I see, that I’m not alone with this problem.

You use the Pro version? Then why don’t you use the official support channel? The Pro license includes mail support by the developers/the distributor.

I guess in that case, I would need to transfer the case to our IT-management.

IT-management? You need consent from IT managemernt to write a simple support request to your Seafile Pro licensor, a request that has no cost consequences? Whatever…

I gave you all the advice I could. If you couldn’t fix your problem with it, reaching out to the Professional support would be my suggestion.