Seadrive killing windows 10 shell after logoff / logon


#1

Hello,
I had 50 Windows 10 1703 workstations with seadrive 0.8.4 installed, and everything was ok, it just works as expected.

things started to go wrong after 1804 upgrade : some users experienced massive explorer slowdown when browsing S: drive.

I decided to install 0.9.5, and now 1.0.0, and days after days things are getting worse : today all the computers were totally unuseable : superfetch service going crazy, explorer totally unresponsive, 5 minutes to display taskmgr and then 5 other minutes to be able to kill seadrive… once killed, everything is going back to normal speed.
Except superfetch (disabled with a gpo)there are no 100% disk or cpu processes in taskmgr. Rebooting sometimes works, but just for the first connexion.

I tried to reinstall totally 1804, and it was ok for the first time, but after logoff / logon, the problem is coming back.

I tried with an user with empty libraries, same disaster.

On mac and linux no problem, it works.

But on Windows, there is a big problem with users profiles. Looks like some process is not killed during logoff, and interferes with next logon ?

seadrive-gui.log has lots of :
Failed to read command from extension(), error code 232
failed to write respone to shell extension : le canal de communication est sur le point d’être fermé