SeaDrive on Ubuntu 18.04

Hi there,

Is there a way to install SeaDrive on Ubuntu 18.04? If not yet, is there an ETD?

Thanks and regards

Not certain about SeaDrive, but someone last week successfully installed Server on 18.04. Have you tried installing Seadrive on it yet?

I dont’t know about Server but I know that Seafile client is installable on 18.04. But SeaDrive is not (dependencies problems).

I can’t confirm this.

It should be - from the official Ubuntu repositories. (What does $ apt policy seafile-gui say?)

I’m new on seafile but I did successfully install seafile server on ubuntu 18.04 without any problems following the seafile tutorials.

The only clients I use are for android / windows platform.

1 Like


Again, my initial post was not about Seafile client (which I know is easily installable and works with no issue on Ubuntu 18.04) nor Seafile server, but about SeaDrive.

We are paying users of Seafile Pro, some users are on Ubuntu, and we can’t upgrade because of that issue. We only use SeaDrive and cannot use Seafile client with our specific situation. Actually even on Ubuntu 16.04 the repo seems to not work anymore and we’re stuck at SeaDrive 0.8.5.

I’m really puzzled that Seafile developpers don’t say a word about it. I know SeaDrive is still in development but that is just one more reason to make it easily installable, otherwise how could we test it?

Please Seafile developpers could you communicate on this? SeaDrive is closed-source and the only way to install it on Linux according to your website is through a method that does not work anymore and doesn’t even apply to Ubuntu 18.04. Even if you can’t do anything about it now, please inform us.


(sorry I’m actually not sure about who the developpers are, if somebody would like to correct this I’d be very grateful :slight_smile: )

Thanks for all the good work anyway.

1 Like

We are working on the issue already. There is a problem with our build server.

1 Like

Hi Daniel. Has there been any resolution to this problem?

I think we have already added build for Ubuntu 18.04. What is your problem now?

 seadrive-daemon : Depends: libcurl3 (>= 7.16.2) but it is not going to be installed

I believe Ubuntu 18.06 uses libcurl4, so any packages that have a libcurl3 requirements will not be installed. seadrive-daemon requires libcurl3.

@daniel.pan Just wondering if you’d had any feedback on this issue. Afaik, there is still no way to install seadrive on Ubuntu 18.04

@Tom_Hampshire we’ve confirmed this problem and we are working on it. Once we fix it we’ll update here. Thanks for reporting!

1 Like

@Tom_Hampshire We rebuild the packages and it should work now. Please try again.

Hi. Thank you for this - however I am still having the same issue. Could you please advise which PPA to use for Ubuntu 16.04?

I can confirm on Ubuntu 18.04, when trying to install seadrive-gui, apt needs to remove libcurl4 and install libcurl3. Any attempt to install software that depends on libcurl4 will result in the removal of libcurl3 and seadrive-gui.

UPDATE: And this now seems to be fixed. Thank you! :slight_smile:

June 2019, still the same issue in Ubuntu 18.04 during installing seadrive. I got an error: “The following packages have unmet dependencies:
seadrive-gui : Depends: seadrive-daemon (= 1.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages”