SeaDrive showing only one library

Hello there,

As I had many problems of synchronization with my Seafile 6.1.0 on my 6.0.7 server (community edition / ~ 40 users), I tried SeaDrive.
I have access to many libraries (~ 20) on the web interface, all are shared with me using a same group.

Only one library is shared with me.
No logic with the library shown (not the first one in alphabetical order, not the smallest, not the most recently updated…)

I used SeaDrive 0.8.0 on Windows (10) or Linux (Archlinux).

Is that a known issue?



SeaDrive not work with Encrypted libraries. Try to remove your account and add it again to SeaDrive, wait for map file tree and check it. I had similar problem with that, resign help, but I must say SeaDrive is not ready for production, have a lot small problems with that which I cant reproduce for report.

I am not using encrypted libraries at all.
I also tried to recreate the account many times, on different computers and operating systems without result.


It seems that we only have one library created on seafile server > 4.0.0.
That’s the reason why only one library is shown in SeaDrive I guess.

A solution have been found about how to upgrade libraries made in seafile < 4.0.0 to the new format of database?



Best practice is backup whole library, delete, create new one a push backuped files into it. There’s big upgrade about libraries (seafile < 4+) that’s not compatible with the new one.