Seafhttp does not work with Reverse Proxy

Hi,

we want to use Seafile with our reverse proxy. We are forwarding all requests on / to Seafile, and /seafhttp to 127.0.0.1:8082, the /media location to the /media path in our seafile folder.

The webinterface works pretty well, however everything located below the /seafhttp path does not work and always return 404 (e.g. /seafhttp/protocol-version returns 404).

I think this has something to do with a missing rewrite - can we change the Path of seafhttp in the configuration so we do not need to rewrite it on our proxy?

/seafhttp cannot be changed.

Thanks for your reply!

If we cannot change the path, which rewrite rules should be set to get /seafhttp working? Simply forwarding it with the whole domain and the path does not work and results in 404 (as written above).

What’s your reverse proxy?

Personally, I tried Nginx but gave up and switched to Caddy, which I found much more intuitive. Here’s my Caddyfile entry for Seafile:

drive.example.com {
        tls my@email.com
        proxy / localhost:8000 {
                transparent
                websocket
        }
        proxy /seafhttp localhost:8082 {
                transparent
                without /seafhttp
        }
}

It works perfectly for me with that setup.

1 Like

I am also using Caddy, the without /seafhttp solved the Problem!

Thank you very much :slight_smile: