Seafile 7.05 on Raspberry Pi, seahub can only be reached from raspberry pi

Ultimately, I want to be able to reach seafile from outside the lan via https. So far, I can only reach the website from the raspberry pi with http://localhost:8000.

If I type “http://raspberrypi” from another computer in the lan, I get the “Welcome to nginx” message.
If I type “http://raspberrypi:8000” from the other computer, it says “connection failed”.
If I type “https://raspberrypi:8000” from the other computer, it says “connection failed”.
If I type “https://raspberrypi:443”, the browser warns me about the unknown certificate, and if I accept the connection, the screen is blank, but I don’t get an error message and there seems to be a connection.
If I type “” (the external url that remains constant), I get “page not found”. This should finally be the address that works, from within the lan and over the internet.

I have spent hours and hours trying to get it to work and am really close to abandoning it all…

I have studied the documents from the seafile manual and so far I don’t get any error messages, but it simply won’t work.

This is my config:

log_format seafileformat '$http_x_forwarded_for $remote_addr [$time_local] "$request" $status $body_bytes_sent "$http_referer" "$http_user_agent" $upstream_response_time';

server {
    listen       80;
    rewrite ^ https://$http_host$request_uri? permanent;        # force redirect http to https

    # Enables or disables emitting nginx version on error pages and in the "Server" response header field.

    server_tokens off;

server {
    listen 443;
      ssl on;
    ssl_certificate /etc/nginx/ssl/seahub.crt;
    ssl_certificate_key /etc/nginx/ssl/seahub.key;
    server_name name;
    server_tokens off;

    location / {
         proxy_set_header   Host $host;
         proxy_set_header   X-Real-IP $remote_addr;
         proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
         proxy_set_header   X-Forwarded-Host $server_name;
         proxy_read_timeout  1200s;

         # used for view/edit office file via Office Online Server

         client_max_body_size 0;
         access_log      /var/log/nginx/seahub.access.log seafileformat;
         error_log       /var/log/nginx/seahub.error.log;

    location /seafhttp {

        rewrite ^/seafhttp(.*)$ $1 break;
        client_max_body_size 0;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
        proxy_send_timeout  36000s;
        send_timeout  36000s;
        access_log      /var/log/nginx/seafhttp.access.log seafileformat;
        error_log       /var/log/nginx/seafhttp.error.log;

    location /media {
        root /home/user/haiwen/seafile-server-latest/seahub;


USER_NAME = RaspbySeafile
ID = 9d88cc649e43d88ba7f66cb168a6323623a21ccd
NAME = RaspbySeafile
PORT = 13419

# -*- coding: utf-8 -*-
SECRET_KEY = "-*Secret_Key"


host =


import os

daemon = True
workers = 5

# default localhost:8000
bind = ""

# Pid
pids_dir = '/home/seafile/haiwen/pids'
pidfile = os.path.join(pids_dir, '')

# for file upload, we need a longer timeout value (default is only 30s, too sho$
timeout = 1200

limit_request_line = 8190

If you have an idea, please help, I am really close to trying my luck with syncthing and abandoning seafile altogether. This is all the more frustrating as my old config worked for more than three years flawlessly. But as the router broke, there is no going back to the old config.

Same problem here.

I installed seafile 7.0.5 on my new raspberry pi 4 (raspbian buster lite) with this instructions:

I didn´t install nginx or config the autostart, so i want to open seafile in the local network. But if i open the local ip/server-adress, my browser tells me, that the website isn´t reachable.

Ok it seems working now. Changed in the gunicorn.conf the "bind = “” to bind = “” like in the manual

I think the server accept all requests now.

Are u able to sync files and folders through the client now?

I was also able to do that before.

With this option, I’m able to down- and upload via webbrowser now.