Seafile 9.0.10 dissappearing files from folder or am I dreaming?

(Running in docker)

I recently tried to access the contents of a folder in a library that I haven’t accessed in a long time via the web-ui and it showed up as empty. I refreshed a few times and suddenly the files appeared but when I clicked on a file it tried to load it for a bit before showing nothing in preview. Clicking “Open in new tab” showed “File not found”.

If I navigated back to the folder I could replicate the behaviour. At first it showed as empty then after some refresh attempts the file list would appear. Trying from my phone showed the listing immediately but with the same “File not found”.

The folder is shared, honestly I do not remember if I had moved / deleted the files, though I assume if I did I would have deleted the folder. Activity shows only the directory’s creation, trash is empty. History is set to keep for ever.

I tried fsck with and without -r, no errors and no files. I did try to upload a file to the folder after which it stopped showing the listing no matter the amount of refresh or via the android app.

Anyone got any ideas or can help figure out what happened? I do not believe I have data loss, all other folders / libraries work fine and pass fsck.
After checking various folders for data loss I think I found the content of that folder residing in another Library as well, not exactly sure but looks like it.

Still the ghost listing in both web-ui and app is not explained. Some kind of caching?

And yea I am planning to upgrade to 10.x