Seafile 9.0.2 Pro - Elasticsearch not working

I upgrading to 9.0.2 I have installed Elasticsearch in Docker according to the installation manual. But now search does not show any results.

Using /pro/ search --update seems to do something, but still no result. Not sure this command even works with external Elasticsearch.

Did anybody succesful got ES to work with 9.x?

1 Like

I have the same problem

This command works with external Elasticsearch.

What output do you have with /pro/ search --update?

Uh… 3 pages of errors. But the first one is as follow:
[ERROR] seafes:92 get_repo_name_mtime_size: ‘ResultProxy’ object has no attribute ‘mappings’

which then repeats few times:
AttributeError: ‘ResultProxy’ object has no attribute ‘mappings’
During handling of the above exception, another exception occurred:

and then again the same error few times.

The reports show than 16 commit read, 0 dir read, 0 file read, 0 block read

To more specify the error: It happens in execution as such:
File “opt/seafile/seafile-pro-server-9.0.2/pro/python/seafes/repo_data/”, line 16, in to_dict
for i in result_proxy.mappings():
AttributeError: ‘ResultProxy’ object has no attribute ‘mappings’

What version of ES do you use?

I installed according to the upgrade guide version 6.8.2 in docker

I had the same Problem … Elasticsearch exists after a few secounds in the Docker version. Is there a way to get LogFiles from Elasticsearch with the reason for the Exit ?

See the other thread on this with the solution:
“I installed ALL pip requirements in both users, root and seafile. This helped and is now working.”

can you share the install command for us ? i have the same problem

pip3 install --timeout=3600 django==3.2.* future mysqlclient pymysql Pillow pylibmc captcha jinja2 sqlalchemy==1.4.3 psd-tools django-pylibmc django-simple-captcha pycryptodome==3.12.0

fix the problem