Seafile and Apache2 on Debian Jessie

Hello,

I installed Seafile on my Debian server and would like to use it behind apache2. Basically, my plan was to have Seahub available on earth.sol.local/seafile instead of earth.sol.local:8000. I followed several tutorials and tried to understand how that is actually working, but without much luck. The seafile server as well as seahub start without errors, but I cannot access them using the browser nor the seafile client.

There is probably a mistake in my config. Any help would be highly appreciated.

Here are my config files:

conf/ccnet.conf:
[General]
USER_NAME = seafile
ID = d58c41cef90e5c1519b53323def736dbc0040ca3
NAME = earth.sol.local
_SERVICE_URL = http://earth.sol.local/seafile

[Client]
PORT = 13419

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD = seafile
DB = ccnet
_CONNECTION_CHARSET = utf8

conf/seahub_settings.py
SECRET_KEY = “)9k-^&e@)cpt#bm%l*(n(ukacq#r&g48!ksje!i+y5upks57=@”

SERVE_STATIC = False
MEDIA_URL = ‘/seafile/media/’
COMPRESS_URL = MEDIA_URL
STATIC_URL = MEDIA_URL + ‘assets/’
SITE_ROOT = ‘/seafile/’
LOGIN_URL = ‘/seafile/accounts/login’
FILE_SERVER_ROOT = ‘http://earth.sol.local/seafhttp

DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub’,
‘USER’: ‘seafile’,
‘PASSWORD’: ‘seafile’,
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’
}
}

/etc/apaches2/sites-available/seafile.conf
<VirtualHost *:80>
DocumentRoot /var/www/seafile
Alias /seafile/media /srv/seafile/seafile-server-6.0.7/seahub/media

RewriteEngine On

<Location /seafile/media>
    ProxyPass !
    Require all granted
</Location>

# seafile fileserver
ProxyPass /seafilehttp http://127.0.0.1:8082
ProxyPassReverse /seafilehttp http://127.0.0.1:8082
RewriteRule ^/seafilehttp - [QSA,L]

ProxyPass /seafhttp http://127.0.0.1:8082
ProxyPassReverse /seafhttp http://127.0.0.1:8082
RewriteRule ^/seafhttp - [QSA,L]

# seahub
RewriteRule ^/seafile$ /seafile/ [L,R=301]
SetEnvIf Request_URI . proxy-fcgi-pathinfo=unescape
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
ProxyPass /seafile fcgi://127.0.0.1:8000/seafile

I created a symlink from sites-available/seafile.conf to sites-enabled/seafile.conf