Seafile Android Client large file uploads fail

Hi,

when I’m trying to upload large video-files (10 GB) via autoupload from my Android device to my seafile server, the upload always fails at around 1.5 GB. The server is located in my LAN and the uploadrate is around 320 Mbit/s, so there shouldn’t be any connection issues. Neither Seafile logs nor Nginx logs show anything about the failed upload.

Seafile-Server Version: 6.2.3 - on Debian 9.3
Seafile Android Version: 2.2.1 - on Android 8.0.0

[details=Nginx (1.10.3) Config:]location /seafhttp { rewrite ^/seafhttp(.*)$ $1 break; proxy_pass http://127.0.0.1:8082; client_max_body_size 0; proxy_connect_timeout 36000s; proxy_read_timeout 36000s; proxy_send_timeout 36000s; proxy_request_buffering off; }[/details]
seafile.conf:

[fileserver]
port = 8082
max_upload_size=20000
max_download_dir_size=20000

[database]
type = mysql
host = 127.0.0.1
port = 3306
user = *******
password = ******
db_name = *****
connection_charset = utf8

[seahub]
port=8000
fastcgi=true

Thanks in advanche!

What size does your temp directory have? Enough system memory/SWAP available?
I suggest you monitor your system using e.g. ‘nmon’ while uploading.

Does uploading from an other device work fine?
Is Android 8 officially supported yet?

Time?
How much time do you allow the server to have a connection?

Please add the following line to seafile.conf
[fileserver]
web_token_expire_time=7200

1 Like

@DerDanilo my temp directory is on the same partition as my main directory, so more than large enough (~800 GB). The system has 16 GB of RAM and only uses around 1 GB when i monitor it while trying to upload the file. I haven’t tried another device yet, I’ll see how it works when i can get my hands on another one. According to the Github Repo of seadroid (compileSdkVersion = 26) it should be supported.

@Calby I use the default value of 3600. Because the server is located in my LAN and I upload with around 320 Mbit/s the upload always fails after about 60 seconds.

You have not specified it in the config file, if I was you I should try to write it in the seafile.conf file just to be sure that it’s not a glitch in the default mode.

It takes 5min to try it :slight_smile:

1 Like

I’ve tried it just now but it still always fails at 1.5 GB uploaded and starts again :worried:
I’ll try to upload the file manually trough Seahub and the Desktop Client and another android device.

Edit: Uploading trough seahub or seafile client works fine. @DerDanilo I tried it with an old Galaxy S5 with Android 6.0.1, the app crashes continuously after about 300 MB uploaded and even when in background mode.

How much space do you have left on the phone itself? Check system space and “media” space.

I’ve around 70 GB left. Seems like its a bug in the android app of Seafile to me.

Anything in the nginx log?