Seafile CE 11.0.3 - Seahub not working after upgrade

Dear Seafile Team,

first of all, thanks for the great work!
I’m now using Seafile for ten years now to sync my files and everything has worked flawlessly until now.

Unfortunately, since the upgrade from 10.0.1 to 11.0.3 seahub is not starting anymore.
While running the upgrade script, I got the warning [WARNING] Failed to execute sql: (1054, “Unknown column ‘domain’ in ‘org_saml_config’”).
I added the column manually afterwards.

When running ./seahub.sh start now, I get the following output:
LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …
Error:Seahub failed to start.
Please try to run “./seahub.sh start” again

No output is written to seahub.log.
Is there any advice on how to get additional debug info for finding the error?
I’m running Seafile on Debian 12.

Thanks and best regards
Florian


Edit:
Found the issue - I was using an old version of python via pyenv.
Anyway, thanks again for providing this great piece of software :slight_smile:

Have exactly the same issue. But I run Python 3.8.10. I run Ubuntu 20.04
I really need help

Hi Flo,

If you go into the Conf file (usually /opt/conf/) then do “nano gunicorn.conf.py”.

In this settings page change “daemon = True” to “daemon = False”.

With this you should now be able to see why the Seahub is failing to start.

If you have any issues, please let me know!

Kind regards,
Mitch