Seafile CE 9.0.7 on Ubuntu 22.04.1

I’ve been running Seafile CE 9.0.7 on Ubuntu server 21.10 for a while without issues, but since Ubuntu 21.10 is no longer receiving updates (yeah I should have gone with a LTS version to begin with) I had to upgrade to Ubuntu 22.04. Now I’m getting the ModuleNotFoundError: No module named 'seaserv' error that I see has popped up several times.

I’ve read through several threads including upgrade-seafile-server-to-ubuntu-22-04/16430 and seafile-community-edition-9-0-5-is-ready/16388/4, and I’ve installed cffi version 1.14.6 in the thirdpart directory as instructed, but it didn’t make a difference for me. I also tried setting up a brand new server in a VM with Ubuntu 22.04.1 and installing Seafile server there because a comment suggested a fresh install worked, but I can’t get this instance to work either, even with the suggested workarounds. Any suggestions?

Python version: 3.10.4
Ubuntu version: 22.04.1

Installing pyenv, changing the cffi version in requirements.txt, and reinstalling dependencies seems to have fixed it. :man_shrugging: I’m not sure how since I did this in my testing VM as well and it did not fix the issue.

To fix another issue with a separate piece of software after I upgraded the server, I also had to set two SSL environment variables:

export SSL_CERT_DIR=/etc/ssl/certs
export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt

I doubt this was related to getting Seafile to work again, but figured I’d mention it just in case it helped anybody.