Seafile-cli on debian 9 no keyserver available

I installed seafile server 6.3.4 on debian 9 lxc. In accordance with the manual I add the signing key

`sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61`

I get the response
Executing: /tmp/apt-key-gpghome.DHgBD2wQVn/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61
gpg: keyserver receive failed: No keyserver available

Hi szehle,
welcome to the Seafile Community Forum!
You say that you followed the manual. Can I ask which one?
I don’t really understand what you are trying to do.
Ralf

Hi Ralf,
I found this manual:
help.seafile.com/en/syncing_client/install_linux_client.html

Debian users can install Seafile client from our debian repo:

To install the client, first add the signing key:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61

But this statement produces this error message

Sorry, my bad. I thought you encountered problems when installing the Seafile Server. I apparently only read the first sentence of your post ("I installed seafile server on debian 9 … in accordance with the manual…), but not the headline.
Unfortunately, I am no Debian user, so I can’t test it. Hope a Debian user reads this post.

First, see if you can even talk to the keyserver. Point your browser on that same machine at this address. http://keyserver.ubuntu.com
It there isn’t a browser on that machine you could just use this command and see if you get a screen full of HTML: curl http://keyserver.ubuntu.com

If that works, just try that command a few times. Maybe the server was just busy. If it doesn’t work, the error you get might help track down the problem (for example it might tell you that there is a problem with your DNS settings).

1 Like