Seafile Client 7.0.3 message "have some sync error"

Since the client version 7.0.3 (on both operating systems Win10 and Ubuntu on different PCs), Seafile shows in the tray icon an exclamation mark with the message “have some sync error”.
If I let the client display the sync errors, I get errors in files that have either already been changed (for example, invalid characters in the file name) or files that no longer exist.
How can I fix the error message?

Thanks in advance!
Server information: Seafile 7.0.5 (Docker Compose), OS: Ubuntu 18.04 (64 bit)

Same issue for me with this last version (7.0.3) on Ubuntu and Manjaro.
In my case the error is related to a conflict that I manually solved 10 days ago. And it appears with the update to the new version, 3 days ago.
I tried to reinstall the client but it did not do the trick. I also tried to desynchronize, then resynchronize the library associated with the erro: No success.

Same question : how can I get read of this (solved) error?

Thanks in advance!

I have the same on Linux Mint and Windows10

ive made a german thread for this issue yesterday https://forum.seafile.com/t/synchronisierungsfehler-bereinigen-unter-linux-mint/10321

same problem on my 4 windows 10 machines… the message appars daily.

Same here. It also lacks the option to clean the sync errors.

I have also the same problem.
Windows 10 1903, Seafile Client 7.0.3, Seafile Comunity Server 7.0.5

Any idea where we can clear sync errors, so we don’t get this error?

Just to let you know: I had the same issue on Windows 8.1 for two days. Today it just magically vanished. Older errors are still in the history. Runs like a charm again. OK for me so far.

Edit: It just came to my mind. I rebooted my server this morning. Give it a try!

Thanks for this advise. Sadly it works not for me. I’ve already restarted my server a cuple of times.

same problem here. all libraries are perfectly in sync. I dont think that there is a issue, but it feels unconftable…

a downgrade would probably get the message away, in a big environment this is a yet not a trivial project.

would be nice if the devs could fix this “cosmetic” issue quick.
@daniel.pan
Thanks

After the opening the file sync errors dialog, the ! should disappear on the tray icon. If you have some repetitive errors, the ! mark may come back later.

Can you give a screenshot about what kinds of errors do you have in the file sync error dialog?

Hello Jonathan,
I do not think a screenshot will help here. The problems with the files are already fixed (for example, the files with special characters have already been renamed).
The exclamation point disappears when you view the sync errors, but it comes back as soon as you restart the Seafile client.
You can also generate the error yourself:

  1. Create a file with unauthorized special characters
  2. Wait until the Seafile client detects the error
  3. rename the file (or delete it altogether)
  4. Restart the client
  5. You will see that the sync error still does not disappear.

Please test once.
Thank you so much!

Hi,

I see the issue. We’ll fix it in the next version.

is there is list of special characters and other “not allowed” file/folder names?

i checked the sync error list and there were some old issues like:

cannot index file xyz.part
cannot access file (used by other application)

all just temporary issues.

after viewing the list, the icon in the task bar is okay again.
nice fix :slight_smile:

And over here … same bug too in 7.0.3.

Now restart the Seafile client once, and you will see the error reappear.
If you look at the sync-error list, the icon in the taskbar will only be temporarily OK.
But as Jonathan already wrote, it will be fixed in the next version.

Thank you.

But is it just a visual notification? Or is there a real sync issue?

Well, it’s actually both: first there is an actual syncronization error, then this is displayed correctly in the client as well.
The problem is that even after the error has been corrected, the error message persists. From then on, it’s just a visual mistake, not a real one anymore.

in my case the issues are very old and I’m quite sure that they are in-sync now, because the libraries are all green.
Thats why I hope its just a visual notification issue.

but when the file (that had an issue) is in-sync later, then the issue should be removed from the list…
Some issues are from files that have even been deleted and are not even at the location anymore…

I also have this bug since 7.0.3.

The sync-error-message-problem is already solved in the new version of the seafile-Client. Just install Version 7.0.4 and the messages only appears once a time.
Good job, thanks to the team!