Seafile Client .deb packages on ubuntu and debian


#21

In 6.1.7 we had to split out the Python libraries to separate packages python-ccnet and python-seafile. Previously, they were included in the lib* packages, but that was actually in violation of the Debian Policy.
But, as I said, this introduction of new binary packages causes their upload to require manual intervention, which increases the time it takes for them to be available.


#22

installing python-ccnet fixes the ImportError, but now i get the same Error when i run seaf-cli start as when i was compiling 6.1.7:
Starting ccnet daemon ...
ccnet: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0: undefined symbol: g_date_copy
CCNet daemon failed to start.


#23

6.1.2. was never in the Debian repositories, so I think you’re talking about the PPA, right?
In Debian, there are no version upgrades of packages within a stable release. So new versions and new packages can only go to testing (until that becomes the new stable release) - that’s why backports was created.


#24

Hey,

that’s weird - I’m running testing and it works for me…
Could you send me the output of apt policy ccnet libglib2.0-0 on your system?


#25

ccnet:
Installiert: 6.1.7-2
Installationskandidat: 6.1.7-2
Versionstabelle:
*** 6.1.7-2 500
500 http://deb.debian.org/debian testing/main amd64 Packages
100 /var/lib/dpkg/status
6.0.4 500
500 http://deb.seadrive.org stretch/main amd64 Packages
libglib2.0-0:
Installiert: 2.56.1-2
Installationskandidat: 2.56.1-2
Versionstabelle:
*** 2.56.1-2 500
500 http://deb.debian.org/debian testing/main amd64 Packages
100 /var/lib/dpkg/status
2.48.0-1~bpo8+1 100
100 http://ftp.debian.org/debian jessie-backports/main amd64 Packages


#26

Ah, so you seem to have lots of other repositories enabled (e.g. “stretch” and “jessie-backports”).
What does lsb_release -a say?


#27

No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux testing (buster)
Release: testing
Codename: buster

I have jessie-backports and seafile ppa but both aren’t used for this?


#28

Do you maybe accidentally use some cruft that was leftover from your compilation?
Could you verify that

$ which ccnet
/usr/bin/ccnet

?
You could also maybe try reinstalling all of the packages:
apt install --reinstall ccnet libccnet0 libglib2.0-0 ?


#29

I deleted the src folder completely and never got to the point of make install so there shoudn’t be anything left.

returns the same for me.

I did the reinstall, same error still.


#30

true, i just setup a VM with a fresh debian testing and its working fine.
Meanwhile i removed every package from non-testing repos and deactivated them.
Then i did a apt install --reinstall on every package that gets installed on a fresh debian testing when you run apt install seafile-cli python-ccnet
Still same error…
Any help is greatly appreciated
EDIT: The files behind the symbolic link /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0->libgobject-2.0.so.0.5600.1 have the exact same date and size on my system and the VM


#31

:slightly_frowning_face:
I have no idea ATM…


#32

Holy cow i fixed it.
This is what i did:
I used ldd to check the shared libraries required by each program or shared object and found a difference to the fresh VM:
ldd -r /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0

returned […] libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 […]
instead of /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
so i went and checked in /lib and indeed there was an old version that didn’t have any package associated with it (check with dpkg -S) so i just deleted the old libraries. Now its working again.


#33

Thanks for doing this. I am using the stretch-backports version for quite a while now and I really appreciate how easy the process of installing was!
Keep up the good work :slight_smile:


#34

Hello again,

Screenshot%20from%202018-06-08%2009-00-44

finally the latest version of the Seafile Client stack (6.1.8) is fully available in the official Debian and Ubuntu repositories. For users of the current stable version of Debian 9 “Stretch”, they are available via the official stretch-backports repository:

If you have any issues with those packages, please report the to the Debian or Ubuntu bug tracking systems using the reportbug tool.

Best wishes,
Moritz
/cc @scheff


#35

How did you solve the problem with qt5Linguisttools on Debian i686?


#36

I don’t know what you’re referring to, but I didn’t do anything special about that.

You can see all the packaging stuff in https://salsa.debian.org/debian/seafile-client/tree/master/debian.


#37

Seems you could ignore it and just build it.
Anyway, thanks.


#38

Hey there,

apt-get upgrade keeps seafile-cli back from being upgraded (stretch-backports).
Everything is working fine - I just want to make sure, that I am not running into trouble due to not being able to update to the latest version.

packages.debian.org claims that libsearpc1 and python-searpc are both available in stretch-backports in version 3.1.0-3~bpo9+2 (see here and here). My system says that both are already at the newest available version, but that is version 3.0.8-1…???

Is there anything I should do? Or just wait until the dependencies are solved?

Here is some terminal output to clarify my little problem:

admin@server:# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  python-seafile seafile-cli seafile-daemon
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
admin@server:# apt-get install python-seafile seafile-cli seafile-daemon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-seafile : Depends: python-searpc (>= 3.1.0) but 3.0.8-1 is to be installed
 seafile-daemon : Depends: libsearpc1 (>= 3.1.0) but 3.0.8-1 is to be installed
E: Unable to correct problems, you have held broken packages.
admin@server:# dpkg -l seafile-cli seafile-daemon python-seafile python-searpc libsearpc1
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                          Version             Architecture        Description
+++-=============================-===================-===================-===============================================================
ii  libsearpc1:armhf              3.0.8-1             armhf               simple and easy-to-use C language RPC framework
ii  python-seafile                6.1.8-1~bpo9+1      all                 Python bindings for the Seafile Client
ii  python-searpc                 3.0.8-1             all                 simple and easy-to-use C language RPC framework
ii  seafile-cli                   6.1.8-1~bpo9+1      armhf               Client CLI for the Seafile Client
ii  seafile-daemon                6.1.8-1~bpo9+1      armhf               Client daemon for the Seafile Client
admin@server:# apt-get install python-searpc libsearpc1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libsearpc1 is already the newest version (3.0.8-1).
python-searpc is already the newest version (3.0.8-1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
admin@server:# cat /etc/apt/sources.list
# See sources.list(5) manpage for more information
# Remember that CD-ROMs, DVDs and such are managed through the apt-cdrom tool.
deb https://deb.debian.org/debian stretch main contrib non-free
deb https://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free

# Uncomment if you want the apt-get source function to work
# deb-src https://deb.debian.org/debian stretch main contrib non-free
# deb-src http://security.debian.org stretch/updates main contrib non-free

deb https://deb.debian.org/debian stretch-backports main contrib non-free
# deb http://ftp.de.debian.org/debian stretch-backports main contrib non-free
# deb-src http://ftp.de.debian.org/debian stretch-backports main contrib non-free
admin@server:#

EDIT:
I solved it myself with

apt-get install -t stretch-backports python-searpc libsearpc1
apt-get upgrade