Seafile Client (GUI or CLI) Debian 9 - repository not working


#1

Hi,

I am trying to install seaf-cli on Debian 9.6, but the repository is not working properly. I follow the instructions in the manual.

Basically running:

  1. sudo apt-key adv --keyserver hkp:// keyserver . ubuntu . com : 80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61
  2. echo deb http: // deb . seadrive . org stretch main | sudo tee /etc/apt/sources.list.d/seafile.list
  3. apt-get update

I then get this:

W: The repository ‘h t t p : / / deb . seadrive . org stretch Release’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch h t t p : / / deb . seadrive . org/dists/stretch/main/binary-amd64/Packages 401 Unauthorized
E: Some index files failed to download. They have been ignored, or old ones used instead.

Trying to curl the site I get this:

curl -I http :// deb . seadrive . org/dists/jessie/main/binary-amd64/Packages
HTTP/1.1 401 Unauthorized
Date: Wed, 06 Feb 2019 18:27:31 GMT
Content-Length: 0
Connection: keep-alive
Set-Cookie: __cfduid=d884530fde7e305d39bfda445bf751ea41549477651; expires=Thu, 06-Feb-20 18:27:31 GMT; path=/; domain=. seadrive . org; HttpOnly
WWW-Authenticate: Basic realm=“Sling (Development)”
CF-Cache-Status: MISS
Server: cloudflare
CF-RAY: 4a4fabd83517c2d3-FRA

Can someone help me install seaf-cli or get the repository to work for Debian 9?


Err:11 http://deb.seadrive.org jessie Release 401 Unauthorized [IP: 104.18.59.193 80]
#2

The devs seem incapable of setting up servers properly as this is not the first time the repositories fail.
I don’t get how they still think they catch customers that think seriously about using Seafile for their company with this many problems it causes.


#3

Was the redirection issue seen last time?


#4

Debian provides seafile-cli in stretch-backports. That is quite convenient to install:


#5

But you should make sure to remove the other sources.list entry beforehand. They might collide.


#6

@schlarbm @Bernie_O thanks a lot both! It works!