SeaFile Client opening and immediately closing on MacOS Sierra

Hi,

I updated to MacOS Sierra a couple of days ago. Seafile worked fine after the upgrade. However since this morning the app opens and the hides the icon. It however doesn’t show itself in the “tray” above. Maybe due to the new Siri icon…

Has anyone been able to solve this?

I have some logfiles:

[09/16/16 08:50:05]starting ccnet:  ("-c", "/Users/michael/.ccnet")
[09/16/16 08:50:06]trying to connect to ccnet daemon...

[09/16/16 08:50:06]connected to ccnet daemon

[09/16/16 08:50:06]starting seaf-daemon:  ("-c", "/Users/michael/.ccnet", "-d", "/Users/michael/Seafile/.seafile-data", "-w", "/Users/michael/Seafile")
[09/16/16 08:50:07][Rpc Client] connected to daemon
[09/16/16 08:50:07][Rpc Client] connected to daemon
[09/16/16 08:50:07][MessageListener] connected to daemon
[09/16/16 08:50:08]Unable to get config value download_limit: Config not exists
[09/16/16 08:50:08]Unable to get config value upload_limit: Config not exists
[09/16/16 08:50:08]QString::arg: Argument missing: &Open bestandsbeheer cloud, Seafile
[09/16/16 08:50:08][Rpc Client] connected to daemon

I can confirm this behaviour. The seafile daemon runs but there is no possibility to use it because
of the missing tray icon :confused:

macOS Sierra will be released around the 20th of september, so it would be nice if the devs could find a quick fix. @daniel.pan

+5 One for each of my Macs in the house.
@daniel.pan

There is another thread that may be relevant to the this one…

On reinstallation you cannot type in the Add an account dialogue box to enter your information, once you do get it installed back and opened.

I give a summary of the problem:

  1. Many users confirm that after upgrading to MacOS 10.12, the Seafile client GUI part stop to work, i.e., the applet icon does not show anymore.
  2. Users confirm that a new installation of Seafile client on MacOS 10.12 works provided that this computer has never installed Seafile client before.

Can anyone confirm that the following steps can’t solve the problem (the first 3 steps should clean all the files that Seafile client has left on the system):

  1. Open Activity Monitor
  2. Search for “Seafile Finder Sync”, “seaf-daemon” and “Seafile”. Stop all of them.
  3. Remove ~/.ccnet and ~/Seafile.
  4. Then reinstall the Seafile App

Because MacOS Sierra (10.12) was released in Sept. 22th and we have a business trip for a week and then followed a national holidays for another week, so we haven’t looked deep into the problem yet.

For my own Mac with upgraded to 10.12, I haven’t encountered the problem yet.

On your Mac, have you tried removing the client, & then reinstalling to see if that will make the problem show?
Or possibly just run the installer again to see if that will make the problem show up?

Hi Daniel, the 3 steps you mention do not help. After the macOS upgrade everything looked fine here too, but if you update or reinstall the client it does not work anymore - try it by yourself and you will see it.

In macos 10.12, I have tried these two cases:

  • reinstall the seafile client
  • remove the client, install seafile client 5.0.7, then upgrade to 5.1.4

I can’t reproduce the problems in both cases.

The next thing I’ll try is to do these steps:

  • run seafile client 5.0.7 on a 10.11 system
  • upgrade to 10.12
  • upgrade to seafile client 5.1.4

And see if that can reproduce the problem.

I can’t reproduce the problem with uninstall Seafile client and install it again. Is it possible that it caused by you once use the preview version of MacOS Sierra?

That is possible Daniel I am using macOS since the first closed beta version.

I only used the beta on one of my Macs. The rest got the final release.

With those steps, I still can’t reproduce the problem.

While we are trying hard to reproduce the problem, maybe you can use the seafile client dock icon menu to access the functionalities (as a temporary workaround) ?

If you disabled the dock icon previously, run this command to get it back:

defaults write ~/Library/Preferences/com.seafile.Seafile\ Client.plist Behavior.hideDockIcon -bool FALSE

Then kill seafile client processes, and restart it.

It seems the problem is disappeared, very weird. I did a complete reinstall of the client 5.1.4 (macOS v10.12.1 beta, 16B2338c) enabled the the dock icon with the “defaults”-command and then I restarted the MBA. It seem everything works like normal again. Later I will try it on my other Mac too. Maybe it has something to do with Apples latest update 2 days ago. I will post the results if I have tried it on my other computer too.

EDIT: It works on my other Mac too - macOS v10.12, the official Release. It seems the “defaults”-command solved the problem. Thank you lins05.

Even I turn on the option “Hide Seafile icon from docker”, I can’t reproduce the problem.

I’ll mark the following command as a workaround if anyone encounter the problem:

defaults write ~/Library/Preferences/com.seafile.Seafile\ Client.plist Behavior.hideDockIcon -bool FALSE

I have this problem, too. Sierra, latest Seafile client. It started after removing the one (and only) account, as I wanted to switch servers. I have tried deleting ~/Seafile and ~/.ccnet but see the same behavior. Running Daniel’s suggested command to turn the dock icon back on doesn’t work either—perhaps because there is no ~/Library/Preferences/com.seafile.Seafile\ Client.plist.

Hey. May be the icon is just “invisible” but working? For me exactly at the first launch I saw the icon. Since then, its invisible but the area is cklickable an the menu appears. I see this behavior on two Macs.

Did you try to do a new clean install as described above ? I got no trouble with the client on macOS anymore.

It was a “clean” install of v 6.0.0 on that machine. And again: Everything works, but the menu bar icon is invisible.