Seafile Client segmentation fault on Arch Linux

I’ve used the Seafile Client successfully for a long time on Arch Linux, but it broke around the 10th of September. Don’t know why, I didn’t upgrade the client or anything. However I ran common OS upgrades. When I try to run seaf-cli start nothing special happens but the client stops running immediately. When trying to run the seafile-applet it justs dumps a segmentation fault.

ccnet.log looks like this:
[10/03/17 01:38:51] …/common/session.c(132): using config file /home/xxx/.ccnet/ccnet.conf
[10/03/17 01:38:51] …/common/session.c(484): Listen on /home/xxx/.ccnet/ccnet.sock for local clients
[10/03/17 01:38:51] …/common/session.c(290): Update pubinfo file
[10/03/17 01:38:52] …/common/session.c(398): Accepted a local client
[10/03/17 01:38:52] …/common/session.c(398): Accepted a local client

seafile.log is empty.

Any ideas? Anyone experiencing the same? Have tried to remove all data dirs (.ccnet, .seafile-client, etc) and no success. Also reinstalled the executables.

Many thanks in advance,


Hmmm… I run Seafile on Arch as well and do not experience such behaviour.
The version I use: seafile-client 6.1.1-1

Latest version of all packages?

Have gotten some output in seafile.log at least. Looks like this:

[10/03/17 13:23:29] ccnet_register_service_sync: Bad response for register service seafile-dummy-service: 1 Network Error[10/03/17 13:23:29] seaf-daemon.c(529): Failed to bind ccnet service

I interpret it as some kind of network error, where network is not available (should this prevent starting the background daemon???) or where the port is busy and not bindable? However, the port shouldn’t be busy and I also tried changing it in ccnet.conf without any difference…


Trying to recompile everything now. Have successfully recompiled libsearpc, ccnet and seafile. However, seafile client fails with the below log output. Is it related to having openssl-1.1 instead of 1.0? How can I specify the openssl libs/includes to use? Tried this syntax without success: cmake -DOPENSSL_LIBRARIES=/usr/lib/openssl-1.0/ -DOPENSSL_INCLUDE_DIRS=/usr/include/openssl ./

LOG OUTPUT (Swedish but you probably understand the important parts, I hope):
/tmp/seafile-client/src/utils/rsa.cpp: I funktion ”RSA* generate_private_key(u_int)”:
/tmp/seafile-client/src/utils/rsa.cpp:137:46: varning: ”RSA* RSA_generate_key(int, long unsigned int, void ()(int, int, void), void*)” bör undvikas [-Wdeprecated-declarations]
priv = RSA_generate_key(bits, 35, NULL, NULL);
In file included from /usr/include/openssl/rsa.h:13:0,
from /usr/include/openssl/x509.h:31,
from /usr/include/openssl/pem.h:17,
from /tmp/seafile-client/src/utils/rsa.cpp:1:
/usr/include/openssl/rsa.h:193:1: anm: deklarerad här
DEPRECATEDIN_0_9_8(RSA *RSA_generate_key(int bits, unsigned long e, void
make[2]: *** [CMakeFiles/utils.dir/build.make:87: CMakeFiles/utils.dir/src/utils/rsa.cpp.o] Fel 1
make[1]: *** [CMakeFiles/Makefile2:393: CMakeFiles/utils.dir/all] Fel 2
make: *** [Makefile:130: all] Fel 2

Moving these compiler problems to new thread since I doubt it’s related to the segmentation fault…