[seafile.conf] host = 127.0.0.1


#1

Hi,
I did look in the manual and I did found out that the host as default is 0.0.0.0 and I just want to make sure that I do understand it correctly.
If your running it with local proxy (nginx or apache2) then you should change that to host = 127.0.0.1 to restrict access?

But I guess that my firewall should also block any attack against it aswell as I guess it’s over port 8082? And I have only port 80 and 443 opened.

But if it’s increasing the security I guess that I could change it, better safe then sorry I guess.


#2

Someone? @daniel.pan @DerDanilo @holantomas


#3

Yes, it’s prevent communication directly over IP and port

Edit: It’s recommended to setup it to 127.0.0.1. But if you are behind NAT or Firewall and don’t have forwarded/enabled 8082, 8000, 12001 ports it’s not nessesary.