Seafile-data on a different location on brand new install (solved)

Hi there!

I’m trying to install seafile-data on a different location. I’m trying to mitigate a bit the speed issues I’ll likely face while using S3 storage, so the rest of the runtimes will be on the main storage, and only the stored data to go to the mounted drive. Hence, seafile-data on a different location as installed. This is all for a home server, so still running on CE version…so no seafile native S3 support, I guess…but I digress.

The installation script “ -d /media/seafile-data” as suggested by the instructions seems to do nothing, and still install on the default path. The old suggestion of editing the seafile.ini at ./ccnet seems to also do nothing, the file doesn’t seem to even be created. Seafile will still use the default path, and refuse to start if it doesn’t find the folder at its default location.

Is the linking the folders option the only suitable one at this point? This gives me also trouble on its own with s3fs and chown…


The manual is the worst. What currently works if symlinking the whole folder seafile-data to wherever you want it to be. Make sure to stop Seafile before.

1 Like

I’ll agree the manual sucks. It really need to be re-done from scratch.
Symlinking worked, as you suggested.



We did this (2 people from the community) with the Seafile manual that you can find on readthedocs. But we don’t have the time and motivation anymore to be honest to keep it up to date.

can you please give examples on how to do this symlink to us new people learning linux and such… say i want to install seafile (*which has been a hard to figure out) onto a 120GB SSD under /opt/seafile but I want all the “MY LIBRARY” and DATA FILES to be stored onto a 10TB hard drive…

I had exactly the same problem here my solution:

move your seafile-data and seahub-data to your new drive/location.
Then create an symlink in the seafile folder with this command:

ln -s [Source_File_Path] [Symbolic_Link_Path] (ln -s /newdrive/seafile/seafile-data seafile-data)