Seafile Docker: LDAPS not working

docker

#1

Hello guys,

right now I set up a docker container to migrate my old seafile-server. On the old server I’ve used ldap to connect to my ad and I want to use this in my new environment with ldaps to get a bit more security :slight_smile:

What I’ve done:
LDAP Connection in docker is working. I can authenticate in the way I want to (memberOf etc.).

Whats my problem:
I cant connect to my active directory (windows server 2016) using ldaps - do you guys have some tips to get this running inside the docker container? I cant find a solution to do this inside my container.

Steps I’ve tried:

  • mounted the cacert from my domaincontroller to /etc/ssl/certs/cacert.crt

  • tried to move the following libs to another location (found this in other threads): liblber-2.4.so.2 libldap-2.4.so.2 libsasl2.so.3 libldap_r-2.4.so.2 (its an ubuntu-image I think - so I tried the “debian-way”. Hope thats right).

  • ccnet.conf:

    [LDAP]
    HOST = ldaps://dc01.domain.tld:636/
    BASE = DNOFBASEOU
    USER_DN = serviceuser@domain.tld
    PASSWORD = password
    LOGIN_ATTR = mail
    FILTER = memberOf=DNOFGROUP

Versions I use:

  • Docker with Rancher v2
  • Latest seafileltd/seafile release
  • Docker/Rancher on newest CentOS.

Thank you guys! Have a nice day :slight_smile:

atomique

Ps.: Authentication with LDAP is working. It must have to do something with my cert / certpath / ldap-libs? I only have a problem with LDAPS / LDAP with TLS

EDIT: Seems like I have the following problem, what do you think? https://github.com/haiwen/seafile-docker/issues/61