Seafile Drive client 0.5.1 is ready! Fix freezing problem in Win7

The changelog:

  • [fix] Fix copying exe files to SeaDrive on Win 7 will freeze the explorer
  • The mounted drive is only visible to the current user
  • Add popup notification when syncing is done
  • [fix] Fix any change in the settings leads to a drive letter change

Note, because the kernel drive is updated to a new version. It is recommended to uninstall the old version then install the new one.

Note, the drive client can’t be used by multi-users in a single machine yet. There is still some code to need be modified in the GUI part. In version 0.6.0, we will support multi-users environment.


really why? why does this installer try to uninstall dokan 0.7.4???
complete wrecked my installation, I still need this for another application
(do not really know what happend, I think I pressed cancel, but anyway this installer should only be concerned about version 1)

now, after uninstallation of seadrive and dokan 1, I tried reinstall 0.7.4, but I cannot.
I get an error “Please uninstall the previous version and restart your computer”,
despite nothing being installed. anyone knows how to reinstall dokany 0.7.4?

google to the rescue, all important stuff seems working again:
uninstall was not fully complete there was still system32\drivers\dokan.sys
so i removed it, then I could reinstall 0.7.4, I also installed newest dokany 1.0.2

now, how to install seadrive without touching my dokany installations?

Still, again, the same question:
ist there command line switch I can use, so the installation does NOT alter my dokany installations?


I’m sorry this is not possible. Dokany since 0.8 breaks backward compatibility. Seafile uses 1.0 version of Dokany. So it’s not possible to use them together. But I’m not very deep into Dokany internals. You could ask Dokany developers.

ist there command line switch I can use, so the installation does NOT alter my dokany installations?

You can achieve that by running the installer from windows command line and adding the nodriver=1 flag:

c:\path\to\seadrive-0.5.1.exe nodriver=1

But as @Jonathan mentions, even if that succeeds, seadrive would not work because dokan 0.7.4 is too old.

yes, I know that 0.7.4 is to old, but I had 0.7.4 an 1.01 installed alongside, so each application can use the version the is required. Up to seadrive version 0.5 this worked fine

However the problem started for me as the installer of 0.5.1 wanted to deinstall 0.7.4, instead of 1.01 to upgrade for 1.02. (I assume the last part)

As I wrote already above now I have currently 0.74 and 1.0.2 manually installed. And sure enough, now I installed seadrive again, so far it works.

her it says officially from the dokany team, that this works:

look for “both dokany version can work side by side so” in the first response