Seafile errors on Windows 11

Hello, I’m using Seafile client fine for a long time. Recently I got a lot of errors from Seafile client (ver 8.0.4) on a newly installed Windows 11 machine. The same version of client works fine on my other machines with Windows 10. All connecting to the same server from the same home network.

Seafile client does retry after these errors and was able to complete sync after a while, but I’m concerned if something is wrong or cause reliability/data corruption down the road.

Anyone also see similar issue with Windows 11?

BTW, following are some of the errors (seems I cannot paste the actual log, just copied the error messages)
[11/01/21 11:09:59] libcurl failed to GET server:port_seafhttp_repo_7a89fa8c-dfc1-43f5-9ab4-e0dd51934e80_block_c508915ef16f77001b4ca8faee8544739388af66: Failure when receiving data from the peer.
[11/01/21 11:09:59] Transfer failed.
[11/01/21 11:09:59] libcurl failed to GET server:port_seafhttp_repo_7a89fa8c-dfc1-43f5-9ab4-e0dd51934e80_block_3b5b76ccb1d028af551b2deb89cd1438d267a854: Failed writing received data to disk/application.
[11/01/21 11:09:59] Transfer failed.

I suspected it’s related to Windows Defender, also tried to add the seaf-daemon.exe and Seafile location to excluded list, but still the same error.