Seafile is not releasing space

After deleting files from seafile + clearing trash + setting history to 0 days seafile is not actually deleting the files, freeing up the space which.

# du -sh seafile-data/
36G	seafile-data/

Screenshot 2020-05-01 at 20.09.15

please advise

You need to run Garbage Collector to free up space: https://download.seafile.com/published/seafile-manual/maintain/seafile_gc.md

Thats pretty annoying. Thank you, worked and fixed it.

I had the same issue after using it for one year: using 27GB but consuming 60GB!

  1. i strongly suggest you add a button that calls this script in the admin interface
  2. If you are using docker pro version on a debian/ubuntu system, below is a command that will create the cron job for you:

replace variables by whatever your setup is

_CONTAINER=seafile-name
_SEALOG=/seafile-standard/seafile-gc.log
sudo bash -c 'cat >/etc/cron.monthly/seafile-gc' <<EOF
#!/bin/sh
# https://download.seafile.com/published/seafile-manual/maintain/seafile_gc.md

echo ------------------------------------------ \$DATE ------------------------------------------ >>$_SEALOG
docker exec $_CONTAINER /scripts/gc.sh >>$_SEALOG 2>&1
echo ------------------------------------------ \$DATE ------------------------------------------ >>$_SEALOG
EOF
sudo chmod 754 /etc/cron.monthly/seafile-gc