Seafile is running fine but noch reachable within LAN

Hey there.

I am runnning a Seafile server. The logs don’t throw any error and the shell says:

[10/30/17 19:37:42] ../common/session.c(132): using config file /home/seafile/conf/ccnet.conf
Starting seafile server, please wait ...
Seafile server started

Done.

Seahub is not running
LC_ALL is not set in ENV, set to en_US.UTF-8
/home/seafile/seafile-server-latest/seahub.sh: Zeile 209: Warnung: setlocale: LC_ALL: Kann die Locale nicht ändern (en_US.UTF-8): Datei oder Verzeichnis nicht gefunden
Starting seahub (fastcgi) at 127.0.0.1:8000 ...

Seahub is started

Done.

In ccnet.conf I set

SERVICE_URL = http://192.168.0.10:8000

But when I try to access http://192.168.0.10:8000, I get a time out in my browser.

The device is connected via LAN cable. When I scan the ports from another computer (also connected with LAN cable) with nmap the result says that port 8000 is closed. Although port 8082 is open. My IPTABLES are:

-A INPUT -s 192.168.0.0/24 -p tcp -m state --state NEW -m tcp --dport 8000 -j ACCEPT
-A INPUT -s 192.168.0.0/24 -p tcp -m state --state NEW -m tcp --dport 8082 -j ACCEPT

So to me it looks like nmap says the port is closed, because the application is not running. But according to the logs it is running.

What am I not seing here? Any help is appriciated!

Regards
bob

Hmm,

first of all try to delete/flush your iptables “sudo iptables -F” then look what “sudo netstat -naptl” says. Is port 8000 / 8082 listening on 0.0.0.0 or 192.168.0.10 or in contrast to the SERVICE_URL setting only on localhost?

It’s running as localhost, not as 192.168.0.10:8000. Maybe this is the problem?

But if, what can I do, I already set the service URL to 192.168.0.10:8000

tcp 0 0 127.0.0.1:8000 0.0.0.0:* LISTEN 20030/python2.7

Oh and if I flush the rules, could this lock me out of the system permanently?

BTW. Did you try to restart seafile and seahub? :smiley:

sure, several times.

where is you cent.conf located? Here /home/seafile/conf/ccnet.conf

perhaps your config isn’t loaded while starting the service…

that’s the location: “/home/seafile/conf/ccnet.conf”

Is there another config that sets the SERVICE_URL?

look good. As far as I know you can overwrite the URL in the Admin Backend.
Login in the GUI and got to “admin panel” goto “settings” there you can overwrite the URL.
perhaps this helps

I would love to do that, but first I need so access it succesfully :slight_smile:

Today I completely reinstalled Seafile but the problems persists.

I also flushed the iptables rules. nmap then said the port is filtered and not closed any more.