Seafile Linux not accepting library password

Hi,

today i setup my Notebook with Ubuntu 22.04 and trying to sync my encrypted folders with my new installation. I can double click my library and type in my password, it shows the content, but when i try to sync the library it always tell me that by password is wrong. Unencrypted librarys work fine.

Anyone know a solution for this?

Seafile Server is Pro 9.0.5
Seafile Client is 8.0.5 from Ubuntu 22.04 Repo.

I tried using Seadrive as workaround for now but it is only available from “linux-clients.seafile.com” and requires libssl1.1 that is no longer provided with Ubuntu 22.04.

Hi,

Do you set encrypted library version in seahub_settings.py? The option looks like:

# version for encrypted library
# should only be `2` or `4`.
# version 3 is insecure (using AES128 encryption) so it's not recommended any more.
ENCRYPTED_LIBRARY_VERSION = 2

If so, which version of encrypted library do you use?

By the way, the official repo doesn’t have packages for 22.04 yet. Where do you get it?

Hi Jonathan,

it is set to “ENCRYPTED_LIBRARY_VERSION = 4”

The package comes from upstream (Debian Team) and is available in the “Ubuntu 22.04 Universe” Repo.

# apt-cache show seafile-gui
Package: seafile-gui
Architecture: amd64
Version: 8.0.5-1
Priority: extra
Section: universe/net
Source: seafile-client
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Seafile Team <team+seafile@tracker.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 3811
Depends: libc6 (>= 2.34), libgcc-s1 (>= 3.3.1), libglib2.0-0 (>= 2.14.0), libjansson4 (>= 2.0.1), libqt5core5a (>= 5.15.1), libqt5dbus5 (>= 5.0.2), libqt5gui5 (>= 5.8.0) | libqt5gui5-gles (>= 5.8.0), libqt5network5 (>= 5.5.0), libqt5webenginewidgets5 (>= 5.7.1), libqt5widgets5 (>= 5.11.0~rc1), libquazip5-1 (>= 0.7.3), libseafile0 (>= 8.0.5), libsearpc1 (>= 3.2.0), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 11), seafile-daemon (>= 8.0.5)
Suggests: seafile-cli (>= 8.0.5)
Filename: pool/universe/s/seafile-client/seafile-gui_8.0.5-1_amd64.deb
Size: 1616464

Any idea on when Seadrive for Ubuntu 22.04 will be released?

I tried to compile seadrive-gui by myself but “dpkg-buildpackage -b” failed with…

/usr/bin/ld: CMakeFiles/seadrive-gui.dir/src/ui/tray-icon.cpp.o: in function SeafileTrayIcon::showMessage(QString const&, QString const&, QString const&, QString const&, QString const&, QSystemTrayIcon::MessageIcon, int) [clone .cold]': tray-icon.cpp:(.text.unlikely+0xc6a): undefined reference to QDBusConnection::~QDBusConnection()’
/usr/bin/ld: tray-icon.cpp:(.text.unlikely+0xc75): undefined reference to `QDBusMessage::~QDBusMessage()’
collect2: error: ld returned 1 exit status

Update: looks like 2.0.16 is latest working version for linux. I compiled SeaDrive 2.0.16 and Seafile GUI 8.0.6 for Ubuntu 22.04. SeaDrive 2.0.16 is able to handle this encrypted Libraries, Seafile Client 8.0.6 not.

Is the library created before or after you changed seahub settings to use v4 encryption?

That is a good question, i remember changing to v4 because something about v3 was not secure and i “think” i rebuild all libraries or the whole server, i cant really remember.

I just installed Seafile 8.0.6 on Windows, no issues syncing the affacted libraries.

Ps. i just created a new encrypted library to be sure it is v4, i cant sync it on Linux, WIndows works fine.

More observation with encrypted libraries

  • Windows: Seafile GUI 8.0.6 works (Official build)
  • Ubuntu 21.10: Seafile GUI 8.0.5 works (Official build)
  • Ubuntu 22.04: Seafile GUI 8.0.5 + 8.0.6 not working (tested with Ubuntu 22.04 Package 8.0.5, self recompiled Debian Package 8.0.6 and Official 8.0.5 20.04 Package)

Thats strange, look like Ubuntu 22.04 instroduced something that breaks encrypted librarie syncing, maybe OpenSSL 3.0.

Update: in seafile.log i can see …/common/seafile-crypt.c(56): Encrypted library version 4 is not supported when i try to sync the new encrypted test library.

It seems there is something wrong with the debian package. With latest version, seafile daemon should support v4 encryption. Perhaps you can report a bug to Debian/Ubuntu.