Seafile mobile (Android and iOS) client UL/DL bug

Hello everyone!

I faced with some troubles with Android an iOs clients, after i changed my Seafile-server for using https (installed Apache and made self-signed certificate). So the problem is that these mobile clients can show me my actual libraries, folders and files, can create/delete files/folders, but can’t download them in to my smartphone and can’t upload any file from smartphone to server ONLY when i am outside my LAN where my Seafile-server stands. But when i am (my smartphones) in LAN – everything is ok and all files
could be uploaded and downloaded.

Here i must show you my connection. I have router with static IP-address on it’s WAN (let it be 1.1.1.1). Behind this router i have LAN where my Seafile-server is with IP-address 192.168.1.10. And of course i forwarded all needed ports (the default 8082 and my new https 443 instead old 8000) from WAN (1.1.1.1) to my Seafile-server (192.168.1.10). So in mobile clients i added my accounts of Seafile-server and set this address: https://1.1.1.1. (heres is the picture for better understanding) [details=Summary]

[/details]

I should add, that to be able to reach my Seafile server from clients and not to change server’s address (from LAN to WAN) everytime when my smartphone not in LAN or in LAN i had to made a “hairpin” rules in my router. So when i am in LAN, all my clients (mobile or desktop) could also connect to my Seafile server via https://1.1.1.1.

I have PC desktop Seafile-clients at home (in my LAN with Seafile-server) and at work on my laptops, and all of them works perfectly with this settings whenever i am in my LAN or out of my LAN – files are syncing without any problems. So the problem is only with mobile clients only when i am out of my LAN. In my router i can see that connection between mobile client and server is established, but when i try to download smth or upload then nothing happens.

So as far in LAN – everithing is ok, then it is not SSL certificate problems. And as far PC desktop clients work in LAN and not in LAN, then it is not port forwarding problems. What it could be? Similar to some mysticism!

BTW, when i used Seafile via http (not https) everything worked perfectly on mobile clients.

Please help me to solve this problem! Maybe i can see seafile client’s logs on my smartphone (my Android smartphone rooted and i have access to any directory), to understand what is happening but i didn’t find any logs.

Thanks in advance!

So, any suggestions from the official developers?

What are your file server root and service url set to?

Thanks for your reply!
Sorry, as far as English is not my native language i think i didn’t understand your question properly. What exactly do you want to know?

There are two config options SERVICE_URL and FILE_SERVER_ROOT. What are they set two?

1 Like

Well, i should say thank you, because a good question sometimes become a good answer!
I had SERVICE_URL=https://192.168.1.10 and HTTP_SERVER_ROOT=https://192.168.1.10/seafhttp. Changed both IPs to 1.1.1.1 and now it works great!

The problem is solved.

Again - thank you very much! :wink: