Seafile on openwrt is not working


#1

I installed seafile 6.2.2 on openwrt. The installation works fine without incidents. I was able to configure it ans tart both seafile and seahub without any errrors. However trying to reach it through web browser on 8000 port gave 500 Internal error afte few tens of seconds. No errors were outputted in any log. I tried to enable debug by writing Debug = True in seahub_settings.py but nothing happened. ccnet.log, controller.log and seahub.log contain very few useless information (no change after DEBUG = True) but seahub.log , seahub_django_request.log, access.log error.log and access.log error.log are empty.

Is there any way to enable more verbose logging, to find out what cause this behavior?


#2

Logging should be always enabled, but be aware of SeaFile’s RAM/Swap probems:


#3

what guide are you following, i am planning on doing this with the latest 18.06.01 version of openwrt but not finding alot of resources regarding the install/config process


#4

If you want data safety with a bigger amount of data, I suggest using another Device extra for Seafile.


#5

even if i add a bunch of swap memory and exroot for drive space? did you try that?


#6

I’m working a lot with Open-/DD-WRT on its limit. And I know the main argument for the is definately not stability. So nothing to store important data. And seafile doesn’t store the raw data + SQlite will be deprecated soon. Just buy a Rock64 and run Seafile on it, it’s worth it. Additionally, you don’t have to care about your data during working on the router.