Seafile: Page not found! and other issues

Hi all!

I’ve been running into all sorts of problems with seafile. I really want to use it but this si killing me.

First problem and by far the biggest is for some reason after a while I’ll get the following error codes when trying to run Seafile in a docker container:

seafile      | 
seafile      | Error happened during creating seafile admin.
seafile      | 
seafile-mysql | 2021-04-27  1:47:57 8 [Warning] Access denied for user 'seafile'@'' (using password: YES)

This error has happened to me multiple times and I can’t figure out why. I do not change any of the permissions or the settings.

To repeat the issue:

  1. Docker-compose up -d
  2. Restore backup (back up works)
  3. Docker-compose down
  4. Docker-compose up -d
  5. Access denied error

It would seem that there is a permissions issue that comes up when restoring the backup. It seems to work as long as I keep the containers running. But it for whatever reason they need to be restarted it fails.

I do have to run the rsync and cp commands with Sudo since docker creates everything as root.

I believe I’ve narrowed the issue down to something related to the ccnet.conf file. However, it gets restored along with the databases. So in theory they should still match. I’ve also tried not restoring it and just leaving the new one generated by the new instance of docker to run the show. It leaves me with the same error.

Issue 2: Along with the access it seem that restoring the backup breaks webdav.

Issue 3: I cannot get the webdav secret to work to enable access through 2FA.

If you have any experience with this or any idea I would greatly appreciate your help.

I’ve been following the instructions for on the Deploy with Docker page for the backup and restore.