Seafile pro 7.02 with Docker crash due to "Cannot allocate memory"

‘’’
Traceback (most recent call last):
File “/scripts/start.py”, line 86, in
main()
File “/scripts/start.py”, line 79, in main
watch_controller()
File “/scripts/start.py”, line 34, in watch_controller
controller_pid = get_command_output(‘ps aux | grep seafile-controller | grep -v grep || true’).strip()
File “/scripts/utils/init.py”, line 173, in get_command_output
return subprocess.check_output(cmd, shell=shell)
File “/usr/lib/python2.7/subprocess.py”, line 216, in check_output
process = Popen(stdout=PIPE, *popenargs, **kwargs)
File “/usr/lib/python2.7/subprocess.py”, line 394, in init
errread, errwrite)
File “/usr/lib/python2.7/subprocess.py”, line 938, in _execute_child
self.pid = os.fork()
OSError: [Errno 12] Cannot allocate memory
*** /scripts/start.py exited with status 1.
*** Shutting down runit daemon (PID 35)…
*** Running /etc/my_init.post_shutdown.d/10_syslog-ng.shutdown…
Oct 28 12:59:39 ad1c7fa34e37 syslog-ng[27]: syslog-ng shutting down; version=‘3.13.2’
*** Killing all processes…
‘’’
I tried to install Seafile server for two Debian9 servers. Both of them report the same error, The 1GB RAM server can operate about 30minute and automatically shutdown, whereas 2GB RAM crashes as I start the container. In addition, I also turn on webdav for them.
Is this due to limited RAM? When the docker container crashes, the whole system always freeze(can’t connect)for a few minutes, sometimes I have to reboot them. However, docker 6.x works well for both of them.