Seafile Pro 7.1.3 with OnlyOffice secret JWT : Blank screen

Hello, I can’t get Seafile 7.1.3 Pro to work with an onlyoffice that has a JWT secret key…
I followed the doc well but I have a blank page.
On my nextcloud it it works well though … :frowning:

And works fine with other server without key …

# Enable Only Office
ENABLE_ONLYOFFICE = True
VERIFY_ONLYOFFICE_CERTIFICATE = False
ONLYOFFICE_APIJS_URL = 'https://xxx.xxx.xx/oo/web-apps/apps/api/documents/api.js'
ONLYOFFICE_JWT_SECRET = 'xxxxxx'
ONLYOFFICE_FILE_EXTENSION = ('doc', 'docx', 'ppt', 'pptx', 'xls', 'xlsx', 'odt', 'fodt', 'odp', 'fodp', 'ods', 'fods')
ONLYOFFICE_EDIT_FILE_EXTENSION = ('doc', 'docx', 'ppt', 'pptx', 'xls', 'xlsx', 'odt', 'fodt', 'odp', 'fodp', 'ods', 'fods')

Hi, what is the exact product you are trying to get to work with seafile? Is it Integration edition, Developer Edition, or Enterprise edition?

As for the problem itself, try following this example and see if it works for you:

# -*- coding: utf-8 -*-
FILE_SERVER_ROOT = "http://your_seafile_domain/seafhttp"   - try adding this line with your seafile address changed
# Enable Only Office

ENABLE_ONLYOFFICE = True
VERIFY_ONLYOFFICE_CERTIFICATE = True  - try setting this value to true
ONLYOFFICE_JWT_SECRET = 'yoursecretword'
ONLYOFFICE_APIJS_URL = "https://xxxxx/web-apps/apps/api/documents/api.js"  - the problem might also occur if api URL is wrong, what does 'oo' stands for in your case? Try making it as in the example, making web-apps go after your domain name
ONLYOFFICE_FILE_EXTENSION = ('doc', 'docx', 'ppt', 'pptx', 'xls', 'xlsx', 'odt', 'fodt', 'odp', 'fodp', 'ods', 'fods')
ONLYOFFICE_EDIT_FILE_EXTENSION = ('docx', 'pptx', 'xlsx')

Hope that helps.