Seafile pro edition 7.1.7 is ready!

This is a maintenance release with following fixes and improvements:

  • [fix] Fix a bug in returned group library permission for SeaDrive client
  • Support pagination when listing libraries in a group
  • Update wsgidav used in WebDAV
  • Remove redundent logs in seafile.log
  • [fix] Fix “save to…” in share link
  • Add an option to show a user’s email in sharing dialog (ENABLE_SHOW_CONTACT_EMAIL_WHEN_SEARCH_USER)
  • [fix] Fix virus scan results page can’t be opened in system admin panel

Hi @daniel.pan

This is a simple but great improvement, thanks !

I noticed that on 7.1.5 version with seaDrive 2.05.
There were also some issues regarding long file path or unwilled characters at the end of the path.
Is it solved ?

Is there any fix planned for this issue ?

View XLSX files does still not work (all other are fine docx, pptx.)

Hi all,

since upgrading to 7.1.7 pro (from 7.0.11 pro) elastic search is not running anymore.

I see the following line repeatedly in the logs:

08/29/2020 13:24:06 [ERROR] seafes:158 start_index_local: Index process init error: ConnectionError(<urllib3.connection.HTTPConnection object at 0x7f1ad013fba8>: Failed to establish a new connection: [Errno 111] Connection refused) caused by: NewConnectionError(<urllib3.connection.HTTPConnection object at 0x7f1ad013fba8>: Failed to establish a new connection: [Errno 111] Connection refused).

[08/29/20 13:32:47] seafile-controller.c(169): bad pidfile format: /srv/seafile/pids/
[08/29/20 13:32:47] seafile-controller.c(588): failed to read pidfile /srv/seafile/pids/ Success

the pid file is empty.

updating the index manually yields the following error:
./ search --update

Updating search index, this may take a while…

/usr/bin/python: No module named queue

Has anybody an idea what went wrong here?

we are running seafile on debian 10.

Many thanks,

Hi @hkunz ,

Everything works fine for me from 7.1.5 to 7.1.11.

You may have a look at the changelog here because you upgraded to from 7.0* to 7.1*


Since seafile-pro 7.0.0, we have upgraded Elasticsearch to 5.6. As Elasticsearch 5.6 relies on the Java 8 environment and can’t run with root, you need to run Seafile with a non-root user and upgrade the Java version.

Please check our document for how to upgrade to 7.0:

Did you have a look here ?

yes, thank you, I checked the upgrade instructions. we are running seafile under the user seafile since a long time. the default version of java in debian 10 ist openjdk-11. anyhow, these were important point when upgrading to 7.0, not from 7.0 to 7.1. elasticsearch was running fine under 7.0.11.

any other ideas?

Can you try to remove the pid file manually and restart the system again?

wow, the simplest idea worked. I feel a bit stupid.

many thanks,

We confirmed that all customers with Shibboleth having this problem. We will include the fix in the next release 7.1.8.


That sounds great :slight_smile: