Seafile Pro install starting issue with Ubuntu

I’ve followed the directions to install the Seafile Pro version (I’m fine with 3 users) except with sqlite using excerpts from all three of the common how-to’s:
https://hostpresto.com/community/tutorials/how-to-install-and-configure-seafile-on-ubuntu-16-04-server/
https://www.howtoforge.com/tutorial/seafile-on-ubuntu-with-nginx/
https://linode.com/docs/applications/cloud-storage/install-seafile-with-nginx-on-ubuntu-1604/

I’ve stopped before the nginx part.

I seem to have it completely installed and working if I manually start the processes:
./seafile.sh stop
./seahub.sh stop

However, when the services runs from systemctl, I cannot access the web page at :8080 like when I run it manually. The strange part is it’s running in the background according to netstat and other commands. If I stop and start if manually, it’s fine.

Any ideas?

Are you using “start-fastcgi” in /lib/systemd/system/seahub.service?

Yes, yes I was. I regret I don’t know what that parameter does, but I just removed it and it works! Thank you!

Is there a reason to put it back, perhaps after I finish the nginx part for https?

What version of Pro are you using? Version 6.2.x fastcgi is not recommended any longer.
https://manual.seafile.com/changelog/changelog-for-seafile-professional-server.html
https://manual.seafile.com/deploy/https_with_nginx.html

Ahh ok. I’ll use those new instructions. I downloaded 6.2.7 Ubuntu.

Thanks again!