Seafile Server 5.1.3 - Tray icon crashes

Hello,

I have Seavile Server 5.1.3 community edition installed on a Windows 10 PC.
Since a few Days, I have some strange problems with the Tray Icon. After I start the server with “run.bat”, the tray icon appears normally. But a few minutes later, the icon is gone, but the server is still running.
So this is only a GUI problem, the server itself works fine.

I found the seafserv-applet.log file, the last few lines are repeating:

[10/01/16 12:16:29] applet/seafserv-applet.c(793): starting seafserv ...
[10/01/16 12:16:29] created "seafserv.exe", pid 6308
[10/01/16 12:16:32] applet/seafserv-applet.c(237): trying to connect to ccnet-sever...
[10/01/16 12:16:32] applet/seafserv-applet.c(263): connected to ccnet server
[10/02/16 21:07:23] applet/trayicon.c(83): WM_TASKBARCREATED received
[10/02/16 21:07:23] applet/trayicon.c(166): trayicon init failed, GLE=1008
[10/02/16 21:07:24] applet/trayicon.c(157): trayicon init failed, retry = 1, GLE=1008
[10/02/16 21:07:25] applet/trayicon.c(157): trayicon init failed, retry = 2, GLE=1008
[10/02/16 21:07:26] applet/trayicon.c(157): trayicon init failed, retry = 3, GLE=1008
[10/04/16 10:31:13] applet/seafserv-applet.c(793): starting seafserv ...
[10/04/16 10:31:13] created "seafserv.exe", pid 9904
[10/04/16 10:31:16] applet/seafserv-applet.c(237): trying to connect to ccnet-sever...
[10/04/16 10:31:16] applet/seafserv-applet.c(263): connected to ccnet server
[10/04/16 10:31:50] applet/seafserv-applet.c(462): SetMenuItemInfoW failed with error 1456
[10/04/16 10:44:16] applet/trayicon.c(83): WM_TASKBARCREATED received
[10/04/16 10:44:19] applet/trayicon.c(83): WM_TASKBARCREATED received
[10/04/16 10:44:19] applet/trayicon.c(166): trayicon init failed, GLE=1008
[10/04/16 10:44:20] applet/trayicon.c(157): trayicon init failed, retry = 1, GLE=1008
[10/04/16 10:44:21] applet/trayicon.c(157): trayicon init failed, retry = 2, GLE=1008
[10/04/16 10:44:22] applet/trayicon.c(157): trayicon init failed, retry = 3, GLE=1008
[10/04/16 10:48:04] applet/seafserv-applet.c(793): starting seafserv ...
[10/04/16 10:48:04] created "seafserv.exe", pid 7588
[10/04/16 10:48:07] applet/seafserv-applet.c(237): trying to connect to ccnet-sever...
[10/04/16 10:48:07] applet/seafserv-applet.c(263): connected to ccnet server
[10/04/16 10:48:51] applet/trayicon.c(83): WM_TASKBARCREATED received
[10/04/16 10:48:53] applet/trayicon.c(166): trayicon init failed, GLE=1008
[10/04/16 10:48:54] applet/trayicon.c(157): trayicon init failed, retry = 1, GLE=1008
[10/04/16 10:48:55] applet/trayicon.c(157): trayicon init failed, retry = 2, GLE=1008
[10/04/16 10:48:56] applet/trayicon.c(157): trayicon init failed, retry = 3, GLE=1008

Do you have any ideas how to fix this issue?

This problem has not occurred for two days, maybe there was another program interrupting… Or reporting the problem was enough that it does not occur anymore :smiley:

If the tray icon crashes again, I will let it know