Seafile Server 6.0.5 for Raspberry Pi is ready! 25.10.2016

You can get it from the Seafile download section.

:pushpin: Please remember:

  • Don’t forget to stop Seafile Server before the upgrade (i.e: service seafile-server stop or, another example: service seahub stop && service seafile stop)
  • Don’t forget to change the directory rights of Seafile after unpacking it (i.e: chown -R seafile:nogroup seafile-server-6.0.5 or, another example: sudo chown -R seafile:seafile seafile-server-6.0.5 )
  • Don’t forget to apply the upgrade script/s according your start release && with the properly user which in normal case should be seafile (i.e change to seafile user: su - seafile -s /bin/bash or, another example: sudo su seafile)

Maybe you wanna check the technical FAQ for further troubleshooting. Many typical workarounds are described there.

Once again, thanks to the developers and Seafile Community

have fun :blush:

5 Likes

Hi all,

upgrading to 6.0.5 I had some kind of problem: Seahub wasn’t displayed right (“text only”) until I restarted the whole server. I always restarted the whole system after upgrading so I wanted to ask: is it necessary to restart the whole server?

Hi @saljut7 I didn’t have that behaviour. I stop always seahub first and then seafile. Maybe this is the point. Maybe any type of cache? You could try to fault isolate methode with the cache. Regards

Thanks for your reply. So does this mean there could be difference between start/stop-script and manual start/stop?

Maybe, in my systemd I have seafile and seahub separately.

1 Like

or maybe caused by this

1 Like

Hi there,

I followed the instructions after untarring the archive
“sudo chown -R seafile:seafile seafile-server-6.0.5”
but after setup I cannot start ./seahub.sh with the normal seafile user.
./seafile.sh starts without problems.

Error:Seahub failed to start.

When I do sudo ./seahub.sh - it starts without complaining. But then I am having problems setting up HTTPS. Please help !

This seems to be what I’m looking for. Will try next time and report. Thanks alot!!

I’ve never understood why there is a separated script for seafile and seahub with systemd: what is the advantage to use systemd in this case (because initd does both in one command)?

Did you try try to chown the whole seafile directory? Did you check the seafile server log directory?

Did you try try to chown the whole seafile directory? Did you check the seafile server log directory?

Hello & thank you for your suggestion.
Yes I tried - I followed https://manual.seafile.com/faq/data-lost.html & Common Problems for Setting up Server - Seafile Admin Manual -

and got it working for the command line. Though for others reading this: I can’t pinpoint which one was the exact culprit.

Next Step: tried to setup at boot (using https://manual.seafile.com/deploy/start_seafile_at_system_bootup.html as template for a tailored script), but here comes the same problem again, seahub.sh only starts with sudo - NOT with sudo -u seafile.

Any ideas ?

Did you check the Seafile server log files?

cat controller.log

[11/21/16 18:57:19] seafile-controller.c(154): starting ccnet-server …
[11/21/16 18:57:19] seafile-controller.c(73): spawn_process: ccnet-server -F /home/seafile/hwb/conf -c /home/seafile/hwb/ccnet -f /home/seafile/hwb/logs/ccnet.log -d -P /home/seafile/hwb/pids/ccnet.pid
[11/21/16 18:57:19] seafile-controller.c(88): spawned ccnet-server, pid 19792
[11/21/16 18:57:20] seafile-controller.c(555): ccnet daemon connected.
[11/21/16 18:57:20] seafile-controller.c(186): starting seaf-server …
[11/21/16 18:57:20] seafile-controller.c(73): spawn_process: seaf-server -F /home/seafile/hwb/conf -c /home/seafile/hwb/ccnet -d /home/seafile/hwb/seafile-data -l /home/seafile/hwb/logs/seafile.log -P /home/seafile/hwb/pids/seaf-server.pid
[11/21/16 18:57:20] seafile-controller.c(88): spawned seaf-server, pid 19799
[11/21/16 18:57:20] seafile-controller.c(528): seafdav not enabled.

cat seafile.log

[11/21/16 18:57:20] …/common/mq-mgr.c(54): [mq client] mq cilent is started

cat seafile.init.log

[11/21/16 18:57:19] …/common/session.c(132): using config file /home/seafile/hwb/conf/ccnet.conf
Starting seafile server, please wait …
Seafile server started

Done.

everything seems normal - only seahub fails ?!

hm… I don’t see some error. Rellay strange. If you don’t have the time to reinstall the Seafile I can only offer you some assisting with SSH. Actually set up of Seafile can be tricky (I remember very well my first not working setups). Contact me via PM if I should assist you via SSH (you could dd your current setup and then create a login for me, after I took a look you can dd your old setup and try again on a “non-touched system”).