Seafile Server 6.0.7 (Windows 10) inaccessible after hard down

Hi all - I am running Seafile 6.0.7 on a Windows 10 machine, and it’s been very reliable. Last night, my landlord was at my shop after I left and I think “helpfully” turned the server off by hitting the power button. I turned the PC back on this morning, but can’t seem to access Seafile.

I’ve restarted the server and the applet shows that it is started and running. None of the clients can access the server (even the client that runs on the same machine as the server instance), and give the error message “Failed to get libraries information”. I’ve tried to access the admin screen via web browser and just get an error message saying “Page unavailable. Sorry, but the requested page is unavailable due to a server hiccup. Our engineers have been notified, so check back later.”

I did try to run garbage collection, which gave me a few errors about repos. I also tried to run seaf-fsck to resolve, but that gives me the following error:

[01/06/21 11:08:16] Can’t load config file C:\Users\rotar/ccnet/ccnet.conf.
[01/06/21 11:08:16] seaf-fsck.c(143): Read config dir error

Any ideas? I’ve got at least 2-3 PCs I use between home and work that access the same library, and not being able to get to the most current file versions is proving to be a problem!

Thanks in advance,


Solved, but not enjoyable. I took the nuclear approach and, after backing up a copy of the corrupted libraries, completely deleted Seafile server and the data folder. After running chkdsk for about a day and having Windows fix multiple errors, I re-installed the server, added new users, and pushed the most currently library back to the server from one of the clients. I have to do the same now for the other user library, but it’s working again.

There’s now a UPS on this machine again, and hopefully future power-related crashes (and subsequent carnage) will be avoided. I understand Windows is no longer supported, but this is still the “easy button” for Windows 10, even if it is getting more out of date. :frowning:

I was for years in the same position. Then I gave up and went for Synology DS218+ and installled docker. Now I am using the “stegerpa-seafile71” container and it’s working like a charm. Essentially it’s a pre installed ubuntu with ngingx and seafile server with sql data base…

I only had to learn a few commands because I had hard shutdowns too and I didn’t know what to do to get the clients connect again. Restarting ./ and ./ wasn’t enough. Also restarting the webserver nginx and sql was needed and everything was back to normal and my customers didn’t have much down time.

Be sure you buy a Synology that can handle docker files because it needs a processor to operate and the family editions don’t have that. Goodluck!