Seafile Server 6.2.1 for Raspberry Pi is ready! 26.09.2017


#21

Updating works fine, thank you @jobenvil ! :slight_smile:


#22

I’m still on 6.0.9 as I did not find the time to add each new release. Today I browsed (hopefully) all announcement threads since then.

Could you share with me what would be the most straight way to go from 6.0.9 to 6.2.2, please?
I’m running a setup of mysql, apache, memcached, fastcgi and use a SSL certificate to only offer https access.

Should I directly go to 6.2.2 release or some minor release in between and only then to 6.2.2?

Any hint is appreciated!


#23
  • first of all read the recommendations on the announcement. This will save you future headaches.
  • Then, when it comes to upgrade seafile, you must start executing upgrade_6.0_6.1.sh and then upgrade_6.1_6.2.sh.
  • Don’t forget to modify at the end the wsgi changes in the nginx blocks.

Good Luck!


#24

Hey, nihilistaX, could you post the content of your ccnet.conf and seahub_settings.py? I’m still trying to troubleshoot this constant ‘502 Bad Gateway’ problem that keeps haunting my Raspberry Pi B+.


#25

Nothing special in this files:

[General]
USER_NAME = myname
ID = 16b275d91aa03872a5d0f5105f7a60c818546548
NAME = myserver
SERVICE_URL = https://mydomain:8001

[Network]
PORT = 10001

[Client]
PORT = 13418

and in seahub_settings.py:

FILE_SERVER_ROOT = 'https://myserver:8001/seafhttp'

other entries are not relevant, but i think your problems are nginx related.

This is my nginx config:

server {
    listen 8002;
	listen [::]:8002;
    server_name 'myserver';
    rewrite ^ https://$server_name:8001$request_uri? permanent; # enforce https
}

server {
    listen 8001 ssl http2;
	listen [::]:8001 ssl http2;
  
	ssl_certificate /etc/letsencrypt/....
    ssl_certificate_key /etc/letsencrypt/live/....
    server_name 'myserver';
 	
	ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_ciphers 'ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-CAMELLIA256-SHA:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-SEED-SHA:DHE-RSA-CAMELLIA128-SHA:HIGH:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!PSK:!SRP:!DSS';
    ssl_prefer_server_ciphers on;
	
	proxy_set_header X-Forwarded-For $remote_addr;
		
    add_header Strict-Transport-Security "max-age=31536000; includeSubdomains";
    server_tokens off;
	
    client_max_body_size 10G; # set max upload size
    
	location / {
        proxy_pass         http://127.0.0.1:8000;
        proxy_set_header   Host $host:8001;
        proxy_set_header   X-Real-IP $remote_addr;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header   X-Forwarded-Host $server_name;
	    		proxy_read_timeout  1200s;
		proxy_http_version 1.1;
	
    #   used for view/edit office file via Office Online Server
        client_max_body_size 0;

	    access_log      /var/log/nginx/seahub.access.log;
        error_log       /var/log/nginx/seahub.error.log;
    }
	
  	
location /seafdav {
        fastcgi_pass    127.0.0.1:8090;
        fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;
        fastcgi_param   PATH_INFO           $fastcgi_script_name;

        fastcgi_param   SERVER_PROTOCOL     $server_protocol;
        fastcgi_param   QUERY_STRING        $query_string;
        fastcgi_param   REQUEST_METHOD      $request_method;
        fastcgi_param   CONTENT_TYPE        $content_type;
        fastcgi_param   CONTENT_LENGTH      $content_length;
        fastcgi_param   SERVER_ADDR         $server_addr;
        fastcgi_param   SERVER_PORT         $server_port;
        fastcgi_param   SERVER_NAME         $server_name;

        fastcgi_param   HTTPS               on;

        client_max_body_size 0;

        access_log      /var/log/nginx/seafdav.access.log;
        error_log       /var/log/nginx/seafdav.error.log;
    }
	
	location /seafhttp {
        rewrite ^/seafhttp(.*)$ $1 break;
        proxy_pass http://127.0.0.1:8082;
        client_max_body_size 0;
		proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
		proxy_send_timeout  36000s;
	    send_timeout  36000s;
        proxy_request_buffering off;
        proxy_http_version 1.1;
	}

#26

Hey, will you build 6.2.3? I tried to build it myself, but as latest try it doesnt work. Building seafile-server, ccnet-server and all others work, but whatever i do, it only produces 6.0.1 files. Maybe you could share your knowledge about how to build, i’m not too advanced doing that, but with official building manual it doesnt work.
Some hint for me?
thx


#27

That you get seafile or ccnet 6.0.1 is completely correct, this is not wrong.The versioning inside ccnet and seafile-server is following another one rule than the produced 6.2.3 release.

Edited: added the word “rule”


#28

Ok, i will retry, but i remember last try the packaging script didn’t accept files with other versions than seahub (which has latest version), but maybe i did something wrong… Btw, it seems hard for someone with low skills in compiling software…


#29

So far so good, i produced all files, now i have ccnet-6.0.1.tar.gz, libsearpc-3.0.7.tar.gz, seafile-6.0.1.tar.gz, seahub-6.2.3.tar.gz, seafobj.tar.gz and seafdav.tar.gz. But if i run packaging script, it says seahub_version is not an option. OK, looked into the script, seems there is no need for that, but it needs version= value. Set that to 6.2.3, but if i run the script, it ends with error “seahub-6.0.1.tar.gz doesnt exist”. Did you see whats going wrong?


#30

Mmm, i give up…anytime i could workaround some issue (like renaming seahub file or copying some files which are not found by packaging script), next error comes. But how did you compile that? Seems the official methode is full of bugs and not useable for someone with deeper knowledge of building that…


#31

you mean here at the gen-tarball.py?


#32

I used packaging script as described in the server manual, is there another way?


#33

no, the mentioned in manual is which I use.


#34

And you never got problems? Now i managed to build tarball, but had to rename seahub tar file, so that it unpacks to 6.0.1 folder in tmp, i had to copy some files, don’t remember what else tried. In the end i have a tarball, but after installing it on test server i got internal server error…so now i really give up and hope you or someone else will build for community :wink:


#35

This is also correct as well. I suppouse that the internal server error is comming from python or third-party module. Which Distro do you use to compile?


#36

Using armbian. But maybe i was wrong, with your build i got internal error, too…but i found out why: I forgot to stop seafile/seahub before upgrading, after that and with restart of components it didnt work. But after going back to previous version, stopping components, upgrading again it works now. Maybe i did the same with my build on my test server and that was the reason for server error. Btw, now all works…


#37

das freut mich :slight_smile:


#38

Mich auch…vielleicht starte ich beim nächsten Update noch mal nen Versuch :wink: