Seafile server 6.3.2 is ready! A few fixes


#1

This is a maintenance release with the following fixes:

  • [fix] Fix error when public wiki be viewed by anonymous users
  • Remove department field in users’ profile page
  • [fix] Print warning instead of abort when there are errors in database table upgrade
  • [fix] Send notification to the upload link creator after there are files uploaded
  • [fix] Fix customize css via “custom/custom.css”
  • [API] return the last modifier in file detail API
  • [fix] Fix ZIP download can’t work in some languages

No groups displayed in admin panel
Seafile Professional Server 6.3 is ready for testing! Major new group functions
#2

I get an JS error in system administration -> groups:
ReferenceError: parent_group_id is not defined in sysadmin-main.92148aa059e0.js (line 129).

Anyone else with this error?


#3

I have not used a wiki before this version, but I decided to try and encounter such strange behavior - the user created a new wiki and installed access for authorized users, another user can not edit the wiki, when clicking the buttons a new page, edit page, delete page appears error - Permission denied.
So it should be or is it a bug?
How can several users work together on a wiki?

Sorry for my bad English


#4

It is a bug. We will fix it in the future.


#5

I get

> 'Loading failed for the <script> with source “https://seafile.address/media/assets/scripts/dist/main.de99968ae34e.js”.'

and

    Error: Script error for: main.de99968ae34e
http://requirejs.org/docs/errors.html#scripterror require.640929dac3c2.js:166:17
makeError
https://seafile.address/media/assets/scripts/lib/require.640929dac3c2.js:166:17
onScriptError
https://seafile.address/media/assets/scripts/lib/require.640929dac3c2.js:1689:36

Due to CSP probably. But worth noting

EDIT: Went away after nginx restart, maybe it’s nothing.


#6

Same to me.
https://seafileserver.com/media/assets/scripts/dist/main.de99968ae34e.js gives a 404


#7

oh this is strange… now it is working?!
I didn’t change nothing!

Maybe it’s a caching issue?


#8

6.3.2 seems to work as normal in general:

Minor bug: Newly created groups appear in selection only after login in again.

Bigger bug:

OnlyOffice is unable to access the file in on the Seafile server, as well as the callback url.
I checked all logs and found nothing.

When opening a file in the browser OO opens as normal, but fails to load the file

The Notification is “Failed to save the document… ‘Ok’ for download”
Then the download failed notification pops up.

Both URL to the Seafile server given to the OO server work as they supposed to, I checked that.

Worked fine under 6.2.5


#9

I’m not seeing a problem with OO under CE 6.3.2/Ubuntu 16.04. I have a couple Seafile servers with co-located OO using subdirectory method and one standalone OO server (also Ubuntu 16.04) that connects to a Seafile via WebDAV. My Docker images are:

onlyoffice/documentserver 5.1.4.22 (all servers)
onlyoffice/communityserver 9.6.1.627 (standalone OO server)

Can you say more about your setup and the problem you’re seeing? Is this happening for all file types? Any errors in the browser debugger or web console?

What do you mean by “When opening a file in the browser OO opens as normal, but fails to load the file”? Do you mean the file opens but does not save changes? That seems to connect with the next comment you make.

-Thanks


#11

@daniel.pan Can you tell me when will the Pro version Docker image be updated?


#13

Hello,

Will you provide a 32 bits version of seafile 6.3 ? I really need it for the yunohost package.


#14

Sorry for the confusing stuff. Was my first post here.

First my specs:
Seafile 6.2.5 server
Seafile 6.3.2 server
DocumentServer (latest version 7 weeks ago. How to get the installed version out of docker?) in a docker container available with subdomain

For the 6.2.5 server everything works as it’s supposed to.

When I open an office document on the 6.3.2. server it connects to the DS and tries to load the document.

Instead of opening the “Document could not be saved” error and a few seconds later “Download failed” pops up.

Surprisingly I didn’t find any logs who give a hint to errer, neither in Seafile nor in apache and both servers are configured the same.

seahub_settings.py:

    # -*- coding: utf-8 -*-
    SECRET_KEY = "xxx
    FILE_SERVER_ROOT = 'https://myclouddomain.de/seafhttp'
    DATABASES = {
        'default': {
            'ENGINE': 'django.db.backends.mysql',
            'NAME': 'seahub-db',
            'USER': 'seafile',
            'PASSWORD': 'xxx',
            'HOST': '127.0.0.1',
            'PORT': '3306'
        }
    }
    ENABLE_ONLYOFFICE = True
    VERIFY_ONLYOFFICE_CERTIFICATE = False
    ONLYOFFICE_APIJS_URL = 'https://myDSdomain.de/web-apps/apps/api/documents/api.js'
    ONLYOFFICE_FILE_EXTENSION = ('doc', 'docx', 'ppt', 'pptx', 'xls', 'xlsx', 'odt', 'fodt', 'odp', 'fodp', 'ods', 'fods')
    ONLYOFFICE_EDIT_FILE_EXTENSION = ('docx', 'pptx', 'xlsx')

ccnet.conf:

[General]
USER_NAME = MyName
ID = b4924c6af9...
NAME = MyName
SERVICE_URL = https://myclouddomain.de

[Client]
PORT = 13419

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD = xxx
DB = ccnet-db
CONNECTION_CHARSET = utf8

apache config Seafile server:

ServerTokens ProductOnly
ServerSignature Off
<VirtualHost *:80>
    ServerName myclouddomain.de
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{HTTP_HOST}/$1 [L,R,NE]
</VirtualHost>


<VirtualHost *:443>
  ServerName myclouddomain.de
  DocumentRoot /var/www

  SSLEngine On
  SSLCertificateFile /etc/letsencrypt/live/myclouddomain.de/cert.pem
  SSLCertificateKeyFile /etc/letsencrypt/live/myclouddomain.de/privkey.pem

  Alias /media  /home/seafile/seafile-server-latest/seahub/media

  <Location /media>
    Require all granted
  </Location>

  RewriteEngine On

  #
  # seafile fileserver
  #
  ProxyPass /seafhttp http://127.0.0.1:8082 timeout=1200 KeepAlive=On
  ProxyPassReverse /seafhttp http://127.0.0.1:8082
  RewriteRule ^/seafhttp - [QSA,L]

  #
  # seahub
  #
  SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
  ProxyPass / http://127.0.0.1:8000/
  ProxyPassReverse / http://127.0.0.1:8000/
</VirtualHost>

apache config DS server:

#Display only Apache as server signature
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
LoadModule headers_module modules/mod_headers.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule ssl_module modules/mod_ssl.so

ServerTokens ProductOnly
ServerSignature Off
<VirtualHost *:80>
    ServerName myDSdomain.de
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{HTTP_HOST}/$1 [L,R,NE]
</VirtualHost>
<IfModule mod_ssl.c>
        # Display only Apache as server signature 
        ServerTokens Prod
        ServerSignature Off
        <VirtualHost *:443>
                ServerName myDSdomain.de
                ProxyPreserveHost On
                # Setup the proxy
                <Proxy *>
                        Require all granted
                        SetEnvIf Host "^(.*)$" THE_HOST=$1
                        RequestHeader setifempty X-Forwarded-Proto https
                        RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
                        ProxyAddHeaders Off
                        Require all granted
                        AllowOverride All
                </Proxy>
                ProxyPass / http://127.0.0.1:88/
                ProxyPassReverse / http://127:0.0.1:88/
                SSLEngine on
                Include /etc/letsencrypt/options-ssl-apache.conf
                SSLCertificateFile /etc/letsencrypt/live/myDSdomain.de/fullchain.pem
                SSLCertificateKeyFile /etc/letsencrypt/live/myDSdomain.de/privkey.pem
        </VirtualHost>
</IfModule>

#16

I found the problem:

The DS server does not even get his request to seahub.

So either there is a failure in the apache config (which I doubt, because the server works well except of OO) or the DS does not accept the certificate of my Fileserver.

Interestingly the server (6.2.5) where OO works fine is on the same machine as then fileserver.

Good new though: it has nothing to do with 6.3.x


#17

Works.

Did nothing what I didn’t do before:

  • reinstalled the ssl certificate
  • reinstalled the document server

#18

Another bug concerning the groups:

In the admin panels sub menu groups the table remains empty. Nevertheless the excel export works as supposed to and contains all groups.

Tested in Safari and Firefox.

[Error] ReferenceError: Can't find variable: parent_group_id
	anonymous (Anonymes Skript 1 (Zeile 5))
	a (sysadmin-main.92148aa059e0.js:129:100073)
	render (sysadmin-main.92148aa059e0.js:129:649348)
	addOne (sysadmin-main.92148aa059e0.js:129:653577)
	forEach
	forEach (sysadmin-main.92148aa059e0.js:129:87409)
	(anonyme Funktion) (sysadmin-main.92148aa059e0.js:129:381855)
	reset (sysadmin-main.92148aa059e0.js:129:653159)
	h (sysadmin-main.92148aa059e0.js:129:372367)
	trigger (sysadmin-main.92148aa059e0.js:129:371619)
	reset (sysadmin-main.92148aa059e0.js:129:379056)
	success (sysadmin-main.92148aa059e0.js:129:380225)
	a (sysadmin-main.92148aa059e0.js:129:39185)
	fireWith (sysadmin-main.92148aa059e0.js:129:39926)
	N (sysadmin-main.92148aa059e0.js:129:75036)
	(anonyme Funktion) (sysadmin-main.92148aa059e0.js:129:79857)

#20

As stated in my post above, I got the same error.


#21

Probably I haven’t noticed this in previous versions but I (as system admin) can’t see any groups in 6.3.2.

A coworker created a group. She is the owner of the group. I can’t see the group in the admin panel.


#22

Same here. Under CE 6.3.2 I can no longer see Groups when logged in as Admin. As a normal user I can see Groups listed under “Shared with groups” menu in sidebar.