Seafile server 7.0 is ready! (Including the CE and PRO edition)


By doing the seafile 7.0.2 to 7.0.3 pro update, there are some errors that appear by going to the user account’s settings page.


2019-06-13 17:12:04,358 [ERROR] seahub.work_weixin.utils:63 work_weixin_base_check work weixin base relevant settings invalid.
2019-06-13 17:12:04,359 [ERROR] seahub.work_weixin.utils:64 work_weixin_base_check WORK_WEIXIN_CORP_ID: 
2019-06-13 17:12:04,359 [ERROR] seahub.work_weixin.utils:65 work_weixin_base_check WORK_WEIXIN_AGENT_SECRET: 
2019-06-13 17:12:04,359 [ERROR] seahub.work_weixin.utils:66 work_weixin_base_check WORK_WEIXIN_ACCESS_TOKEN_URL:

what is this internet address in the log file ??? what is it for ???

the security certificate corresponds to this website
Daniel can you give us more information? thank you

1 Like

There shouldn’t be any external service requirements for seafile otherwise it will loose the given trust very quickly as ones data is potentially unsave.


Daniel I assume you guys will focus on stabelizing and enhancing 7.x from now on?
So no more effort put into 6.x and no parallel maintenance of 6 and 7?
I would do so, not moaning, just want to know about the future of 6.x from today on, so that I can make the internal decision when to migrate…

Thanks alot for doing a good job on Seafile.

Upgrade from 7.0.2 ran smoothly.

I noted a great many little improvements in Seahub:

  • New library icons for shared libraries with the new permissions (preview on cloud and preview-edit on cloud)
  • Picture thumbnails in the file details
  • File comments available in file details
  • More sorting functions
  • Context-dependent icons (for tables) in MD editor

I only encountered one (small) problem: In Firefox, I couldn’t scroll on the personal settings page (see screenshot, note that there is no scroll bar on the right). In Chrome, scrolling works as expected.

After my tests, I have two questions @daniel.pan :
1.) Was I just too blind to find the internal/smart link function or hasn’t it been implemented in the new UI yet?
2.) Will you also migrate the admin panel to the new UI?

Thanks for Seafile 7.0.3. We will most likely migrate within the coming week.

This does not seem to be a general problem. It works just fine here.

Same thing for this one. I had no problem. Did you try with different browsers - especially Chrome?

For the first two problems, can you try to refresh the page?

For file types not listed in the suffix , histories version will be scanned from the library history as before.

We will check the problem.

The internal link feature is only present in the file view page:


It will be rewritten in 7.1.


Yes, we will focus on stabelizing and enhancing 7.x from now on.


We will check the problem.

weixin is a popular messaging app in China. The feature is to support single sign on with weixin.

1 Like

Thanks. It is added now.

That means I cannot generate internal links for pictures as well as office files when I use ONLYOFFICE/Collabora?

For pictures, you can open it in a new tab via the link “Open in New Tab”


For office files using ONLYOFFICE/Collabora, the internal link feature is not available now.

I use a self hosted software to be “not linked” at all to any big cloud provider.
Now you just added a connection, really?

While the files are still local, this still in my view partially defeats the purpose of using Seafile

Please show a connection. I doubt there is one as the log only states the feature has not been configured.

1 Like

Having upgrade warnings Got MySQL warnings when upgraded from 6.3 to 7.0

Have some UI issues after upgrade from 6.3 CE to 7.0.2 CE

ICON Display Issues on Toolbar

SOLVED: thanks to Cisco A simple delete of browser cache solved it. had to do ti on all browsers

1 Like

It is a feature like the OAuth feature via Google and it is turned off by default.


Hi @daniel.pan

I have been testing Seafile Pro 7.0.3 for a week now.

On mobile devices (like iPhone 8) your rewritten UI seems not quite production ready.

I also noticed that saving markdown files after editing them in the WebUI works but users get an error.
I am getting the following error in nginx:

2019/06/21 07:11:11 [error] 22352#22352: *20361 upstream prematurely closed connection while reading upstream, client: XXX.XXX.XXX.XXX, server: XXXXXX, request: "POST /seafhttp/update-api/c0889161-8950-410d-8ea6-9bf6851c6d2c HTTP/2.0", upstream: "", host: "XXXXXXXX", referrer: "https://xxxxxxxxxx/lib/dc26e32b-71b9-4273-bc64-202af6fb6ba8/file/"

Furthermore I am not able to replace an existing file using the WebUI. I am able to upload a file once. If I reupload the same file and choose to replace the first one I am getting the following error.

I am using Firefox for testing. Seafile runs on Debian.

Thanks a lot for your constant development.

1 Like

Found an issue:
Server: CE 7.0.2, Client: WIndows 7.0.0
When i select a library in the client and go to -> view on cloud, the link just takes me to the library overview of all my libraries rather than the library i wanted to see. Url seems to be valid tough.

URL: #common/lib/326c1496-ea18-47ff-bfb4-9f483376fb44/
Looks like a seahub issue

The URL for libraries is changes. We will look into the problem.