Seafile Server 7.1.3 vs. Ubuntu 16.04 / Python 3.5


I was not able to get a reliable information regarding the above combination. Does the requirement ‘Python3’ include Python 3.5 (e.g. on Ubuntu 16.04). Could somebody please confirm that this is viable!

Thanks in advance for a short reply.



Hi Mark, version 3.6 is necessary.

Many thanks for your reply!

Regarding EOL of Ubuntu 16.04 ist 04/2021 this is unpleasant. This means Seafile will not run “out of the box” and messing arround with different python-packages is most of the time an issue. On the other hand it is completely understandable that “seafile-life” goes on (and very much apprechiated).

Is there as “best practice” to get Seafile up and running with Ubuntu 16.04 / Python 3.5 (ex. Docker). I would give ‘pyenv’ a try but don’t want to reinvent the wheel. If I got it right, ‘pyenv’ would give the user “seafile” an exclusive Python 3.6 (3.7) environment (might be wrong / did not check in depth, yet).

Thanks for helping me think about that in advance.



Hi Mark,

I upgraded to 7.1.3 on a 16.04 server and ended up upgrading Ubuntu to 18.04 just to satisfy the resulting dependencies, because it seemed to be the easiest way. After satisfying all Python dependencies, Seahub (at least I think so) did not start because some of the libraries Seafile brings along were compiled against a newer version of glibc. And instead of downgrading Seafile, I made the step forward and upgraded Ubuntu. I don’t know why 16.04 is still listed as compatible with version 7.1… So be prepared. :wink:

Kind regards,

Hi Daniel,

OK, thanks for sharing this! This is a no-go on my system at the moment.

To hoom it may concern:

It would be great if you could clarify the requirements for the different server / clients. At least for the common LTS versions. Taking a look at your current list client is not supported on Windows 8.1 … which is not true on my side.

I had similar experience. Debian stretch (oldstable) uses libc6=GLIBC_2.24 and stops with Python at version 3.5. In order to have Python >=3.5 and avoid between others this well known issue I did a distro upgrade to Buster (stable) which upgrades the libc6 library to 2.28. Among other fixable problems, the upgrade broke some other dependencies like libevhtp* which I need to compile the raspberry pi version. After fixing that and compiling succesfully the pi version I found out, that on the server that I’m running the Seafile application, JUST-ONLY-AND-UNFORTUNATEDLY the GLIBC version was the 2.27, therefore I could not start Seafile. The Distro which ships the 2.27 is the Ubuntu Bionic… just for fun. If you compile something in Debian Buster, this probably will not work on Ubuntu Bionic…

Now what? Just I took a one month old backup from Raspbian Stretch and right now compiling python 3.7.7 for stretch since two hours…this way should be guaranted backwards compatibility for libc6.

Nevertheless, this is a good hour for stretch users (if it works the python compilation and later on, the seafile build…)

… meanwhile the compilation of python took more than 4 hours and was succesfully …

Total duration: 3 hour 51 min
Tests result: SUCCESS
make[1]: Leaving directory '/media/usbfestplatte/NAS/Python-3.7.7'
make build_all_merge_profile
make[1]: Entering directory '/media/usbfestplatte/NAS/Python-3.7.7'
make[1]: Leaving directory '/media/usbfestplatte/NAS/Python-3.7.7'
1 Like

Thanks for reporting your findings. For me that means, that I won’t upgrade to 7.1.3 in the foreseeable future. I guess I’ll wait half year or so and then move to Ubuntu 20…