Seafile Server Docker Container Stops Unexpectedly


#1

I am trying to install Seafile Server Community Edition on Ubuntu 18.04 using a Docker container according to the instructions manual[dot]seafile[dot]com/deploy/deploy_with_docker[dot]html. I am new to Docker, but I am using it bc/I thought it would involve less error-prone setup and easier updates.

This is the command that I ran:

sudo docker run -d --name  seafile \
 -e SEAFILE_SERVER_LETSENCRYPT=true \
 -e SEAFILE_SERVER_HOSTNAME=example.com \
 -e SEAFILE_ADMIN_EMAIL=example@gmail.com \
 -e SEAFILE_ADMIN_PASSWORD=verysafepassword1234 \
 -v /opt/seafile-data:/shared \
 -p 80:80 \
 -p 443:443 \
 seafileltd/seafile:latest

Then I ran this:

$ docker container ls -a
CONTAINER ID        IMAGE                       COMMAND                  CREATED             STATUS                     PORTS               NAMES
c4a4d6b58882        seafileltd/seafile:latest   "/sbin/my_init -- /s…"   15 seconds ago      Exited (1) 3 seconds ago                       seafile

It looks like seafile container stopped after 12 seconds.

If I run docker start seafile, the seafile container seems to start, but then quits after 12 seconds again.

This file /opt/seafile-data/logs/var-log/messages on the server shows lines like this from whenever I try to start the container:

Jan 26 23:59:55 c4a4d6b58882 syslog-ng[18]: syslog-ng starting up; version='3.13.2'
Jan 27 00:00:02 c4a4d6b58882 syslog-ng[18]: syslog-ng shutting down; version='3.13.2'

I don’t imagine I’m providing the right information, so could someone please just point me in the right direction for troubleshooting why the Docker container stops unexpectedly like this? Danke.