Seafile Server failing on Debian Stretch

I can’t get the seafile server to start under Debian Stretch, but it starts fine under Debian 8 (Jessie). Does anybody experience this? If so do you know a workaround? I’ll file a bug report, but thought I’d check here too…

Minimal Steps To Reproduce

Easiest way to reproduce is to use docker as then you can quickly compare two versions of Debian.

If I run:

docker run -t -i debian:latest /bin/bash
apt-get update; apt-get install -y wget python2.7 libpython2.7 python-setuptools python-imaging python-ldap python-urllib3 sqlite3
wget https://download.seadrive.org/seafile-server_6.1.2_x86-64.tar.gz
tar -zxvf seafile-server_6.1.2_x86-64.tar.gz
seafile-server-6.1.2/setup-seafile.sh auto -n testing -i testing.com
seafile-server-latest/seafile.sh start

Then I get:

[08/20/17 08:19:31] …/common/session.c(132): using config file /conf/ccnet.conf
Starting seafile server, please wait …
Failed to start seafile server

But if I replace debian:latest with debian:8 the seafile server starts fine.

I am under debian stretch 9.1 and my server seafile pro 6.1.8 works wonderfully I do not use docker, I followed this manual to install seafile:
https://manual.seafile.com/deploy_pro/download_and_setup_seafile_professional_server.html
and
https://manual.seafile.com/deploy/using_mysql.html
I use mariadb , openjdk-8-jre , Nginx

Hmm, latest community edition is only 6.1.2, I wonder if there’s a fix that hasn’t been added to the community edition yet. Or possibly the pro edition bundles different libraries anyway… I don’t know how similar they are…

Haven’t tried without docker, as for my use case I need it.

I use Seafile Community Edition 6.1.1 with Debian Stretch. It’s running without any problems…
EDIT: I don’t use docker though.

That’s strange. I can’t imagine much has changed between 6.1.1 and 6.1.2. Docker images are based on stripped down versions of the main tree so that shouldn’t make much of a difference either. I wonder if a “full” version of Debian has some additional libraries kicking around that get used in preference to those bundled with seafile, whereas the stripped down Docker image doesn’t and so that’s why the error becomes apparent.

Meanwhile I updated to Seafile Community Edition 6.1.2
Everything is working with my Installation (Debian 9.1; no docker).