Seafile Server Pro 5.1.11 FileAccess no IP/Device

Hello!
I have Seafile Server Pro 5.1.11 with MySQL and Nginx on Ubuntu 16.04. I have one a little problem: No data about IP/Device on page Logs->FileAccess.
Server: Ubuntu 16.04.1 LTS
Nginx version: nginx/1.10.0
Configuration nginx:
server { listen 80; server_name MY_SERVER_NAME; rewrite ^ https://$http_host$request_uri? permanent; # force redirect http to https } server { listen 443; ssl on; ssl_certificate PATH_TO_CERT; # path to your cacert.pem ssl_certificate_key PATH_TO_KEY; # path to your privkey.pem server_name MY_SERVER_NAME; proxy_set_header X-Forwarded-For $remote_addr; add_header Strict-Transport-Security "max-age=31536000; includeSubDomains"; server_tokens off; location / { fastcgi_pass 127.0.0.1:8000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_script_name; fastcgi_param SERVER_PROTOCOL $server_protocol; fastcgi_param QUERY_STRING $query_string; fastcgi_param REQUEST_METHOD $request_method; fastcgi_param CONTENT_TYPE $content_type; fastcgi_param CONTENT_LENGTH $content_length; fastcgi_param SERVER_ADDR $server_addr; fastcgi_param SERVER_PORT $server_port; fastcgi_param SERVER_NAME $server_name; fastcgi_param HTTPS on; fastcgi_param HTTP_SCHEME https; access_log /var/log/nginx/seahub.access.log; error_log /var/log/nginx/seahub.error.log; fastcgi_read_timeout 36000; } location /seafhttp { rewrite ^/seafhttp(.*)$ $1 break; proxy_pass http://127.0.0.1:8082; client_max_body_size 0; proxy_request_buffering off; proxy_connect_timeout 36000s; proxy_read_timeout 36000s; proxy_send_timeout 36000s; send_timeout 36000s; } location /media { root /opt/seafile-pro/seafile-server-latest/seahub; } }
Please help me solved this problem.

You find the answer here: No IP addresses in seahub.log
:blush:

1 Like

What I can tell? I should have read carefully the instructions. Although it should be noted that in the manual, this parameter is missing in Section Nginh + ssl. Thank you very much for your help.

You are welcome :blush:
You are right, it would be good to add this to the nginx with ssl manual site too!
@daniel.pan?

Thanks. It is fixed.